Phoenix Contact: PLCnext Engineer Vulnerabilities in LibGit2Sharp/LibGit2
Several vulnerabilities have been discovered in the LibGit2Sharp or underlying LibGit2 library.This open-source component is widely used in a lot of products worldwide.The product is vulnerable to remote code execution, privilege escalation and tampering.PLCnext Engineer is using the LibGit2Sharp library to provide version control capabilities.
describes (11)
Related CVEs.
| ID | severity | exploitable | ||
|---|---|---|---|---|
| CVE-2022-29187US | high7.8 | — | ||
Git is a distributed revision control system. Git prior to versions 2.37.1, 2.36.2, 2.35.4, 2.34.4, 2.33.4, 2.32.3, 2.31.4, and 2.30.5, is vulnerable to privilege escalation in all… | ||||
| CVE-2022-24765US | high7.8 | — | ||
Git for Windows is a fork of Git containing Windows-specific patches. This vulnerability affects users working on multi-user machines, where untrusted parties have write access to… | ||||
| CVE-2019-1353US | critical9.8 | — | ||
An issue was found in Git before v2.24.1, v2.23.1, v2.22.2, v2.21.1, v2.20.2, v2.19.3, v2.18.2, v2.17.3, v2.16.6, v2.15.4, and v2.14.6. When running Git in the Windows Subsystem fo… | ||||
| CVE-2019-1348US | low3.3 | — | ||
An issue was found in Git before v2.24.1, v2.23.1, v2.22.2, v2.21.1, v2.20.2, v2.19.3, v2.18.2, v2.17.3, v2.16.6, v2.15.4, and v2.14.6. The --export-marks option of git fast-import… | ||||
| CVE-2019-1354US | high8.8 | — | ||
A remote code execution vulnerability exists when Git for Visual Studio improperly sanitizes input, aka 'Git for Visual Studio Remote Code Execution Vulnerability'. This CVE ID is… | ||||
| CVE-2019-1352US | high8.8 | — | ||
A remote code execution vulnerability exists when Git for Visual Studio improperly sanitizes input, aka 'Git for Visual Studio Remote Code Execution Vulnerability'. This CVE ID is… | ||||
| CVE-2019-1351US | high7.5 | Exploit | ||
A tampering vulnerability exists when Git for Visual Studio improperly handles virtual drive paths, aka 'Git for Visual Studio Tampering Vulnerability'. | ||||
| CVE-2019-1350US | high8.8 | — | ||
A remote code execution vulnerability exists when Git for Visual Studio improperly sanitizes input, aka 'Git for Visual Studio Remote Code Execution Vulnerability'. This CVE ID is… | ||||
| CVE-2019-1349US | high8.8 | — | ||
A remote code execution vulnerability exists when Git for Visual Studio improperly sanitizes input, aka 'Git for Visual Studio Remote Code Execution Vulnerability'. This CVE ID is… | ||||
| CVE-2019-1387US | high8.8 | — | ||
An issue was found in Git before v2.24.1, v2.23.1, v2.22.2, v2.21.1, v2.20.2, v2.19.3, v2.18.2, v2.17.3, v2.16.6, v2.15.4, and v2.14.6. Recursive clones are currently affected by a… | ||||
| CVE-2018-11235US | high7.8 | Exploit | ||
In Git before 2.13.7, 2.14.x before 2.14.4, 2.15.x before 2.15.2, 2.16.x before 2.16.4, and 2.17.x before 2.17.1, remote code execution can occur. With a crafted .gitmodules file,… | ||||
references
External citations — patches, advisories, analysis.
remediations (22)
- MitigationPLCnext Engineer
To mitigate aforementioned vulnerabilities the integrity and authenticity of the git configuration data must be ensured. Otherwise, we kindly advise you to refrain from using the version control feature in version lower than 2023.6
- MitigationPLCnext Engineer
To mitigate aforementioned vulnerabilities the integrity and authenticity of the git configuration data must be ensured. Otherwise, we kindly advise you to refrain from using the version control feature in version lower than 2023.6
- MitigationPLCnext Engineer
To mitigate aforementioned vulnerabilities the integrity and authenticity of the git configuration data must be ensured. Otherwise, we kindly advise you to refrain from using the version control feature in version lower than 2023.6
- MitigationPLCnext Engineer
To mitigate aforementioned vulnerabilities the integrity and authenticity of the git configuration data must be ensured. Otherwise, we kindly advise you to refrain from using the version control feature in version lower than 2023.6
- MitigationPLCnext Engineer
To mitigate aforementioned vulnerabilities the integrity and authenticity of the git configuration data must be ensured. Otherwise, we kindly advise you to refrain from using the version control feature in version lower than 2023.6
- MitigationPLCnext Engineer
To mitigate aforementioned vulnerabilities the integrity and authenticity of the git configuration data must be ensured. Otherwise, we kindly advise you to refrain from using the version control feature in version lower than 2023.6
- MitigationPLCnext Engineer
To mitigate aforementioned vulnerabilities the integrity and authenticity of the git configuration data must be ensured. Otherwise, we kindly advise you to refrain from using the version control feature in version lower than 2023.6
- MitigationPLCnext Engineer
To mitigate aforementioned vulnerabilities the integrity and authenticity of the git configuration data must be ensured. Otherwise, we kindly advise you to refrain from using the version control feature in version lower than 2023.6
- MitigationPLCnext Engineer
To mitigate aforementioned vulnerabilities the integrity and authenticity of the git configuration data must be ensured. Otherwise, we kindly advise you to refrain from using the version control feature in version lower than 2023.6
- MitigationPLCnext Engineer
To mitigate aforementioned vulnerabilities the integrity and authenticity of the git configuration data must be ensured. Otherwise, we kindly advise you to refrain from using the version control feature in version lower than 2023.6
- MitigationPLCnext Engineer
To mitigate aforementioned vulnerabilities the integrity and authenticity of the git configuration data must be ensured. Otherwise, we kindly advise you to refrain from using the version control feature in version lower than 2023.6
- FixedPLCnext Engineer
Update PLCnext Engineer to 2023.6.
- FixedPLCnext Engineer
Update PLCnext Engineer to 2023.6.
- FixedPLCnext Engineer
Update PLCnext Engineer to 2023.6.
- FixedPLCnext Engineer
Update PLCnext Engineer to 2023.6.
- FixedPLCnext Engineer
Update PLCnext Engineer to 2023.6.
- FixedPLCnext Engineer
Update PLCnext Engineer to 2023.6.
- FixedPLCnext Engineer
Update PLCnext Engineer to 2023.6.
- FixedPLCnext Engineer
Update PLCnext Engineer to 2023.6.
- FixedPLCnext Engineer
Update PLCnext Engineer to 2023.6.
- FixedPLCnext Engineer
Update PLCnext Engineer to 2023.6.
- FixedPLCnext Engineer
Update PLCnext Engineer to 2023.6.
Advisories like this name the exposed products attackers go after on your perimeter. See what is exposed on your perimeter with a free passive scan.
Free scan