CVE-2018-11235
mediumpriority · attend · 58EPSS 0.481 · 99 %ileexploit · PoCDEEURUUSEPSS · scored 2026-10-27
In Git before 2.13.7, 2.14.x before 2.14.4, 2.15.x before 2.15.2, 2.16.x before 2.16.4, and 2.17.x before 2.17.1, remote code execution can occur. With a crafted .gitmodules file, a malicious project can execute an arbitrary script on a machine that runs "git clone --recurse-submodules" because submodule "names" are obtained from this file, and then appended to $GIT_DIR/modules, leading to directory traversal with "../" in a name. Finally, post-checkout hooks from a submodule are executed, bypassing the intended design in which hooks are not obtained from a remote server.
remediations
Vendor fix, mitigation, or workaround guidance, as published by each source.
A vendor fix is available.
- FixedPLCnext Engineerphoenix_contact_psirt
Update PLCnext Engineer to 2023.6.
- MitigationPLCnext Engineerphoenix_contact_psirt
To mitigate aforementioned vulnerabilities the integrity and authenticity of the git configuration data must be ensured. Otherwise, we kindly advise you to refrain from using the version control feature in version lower than 2023.6
cvss
Technical severity, 0–10. One row per scoring source.
base score 0–10 · higher = more severe · hover a vector to decode⚠ sources disagree · medium–high · 6.8–7.8
weaknesses
The CWE weakness classes this flaw belongs to.
exploits (15)
Public proof-of-concept and weaponised exploit code.
- AnonymKing/CVE-2018-11235CVE-2018-11235(PoC && Exp)PoC · poc_in_github
- CHYbeta/CVE-2018-11235-DEMOCHYbeta/CVE-2018-11235-DEMOPoC · poc_in_github
- H0K5/clone_and_pwnExploits CVE-2018-11235PoC · poc_in_github
- Kiss-sh0t/CVE-2018-11235-pocfor git v2.7.4PoC · poc_in_github
- Rezy-Dev/CVE-2018-11235exploit poc for CVE-2018-11235PoC · poc_in_github
affected products (28)
Products and version ranges known to be affected.
advisories (1)
Vendor and ecosystem advisories describing this.
- VDE-2023-016Phoenix Contact: PLCnext Engineer Vulnerabilities in LibGit2Sharp/LibGit22023-08-08csaf · phoenix_contact_psirtDE
Several vulnerabilities have been discovered in the LibGit2Sharp or underlying LibGit2 library.This open-source component is widely used in a lot of products worldwide.The product is vulnerable to remote code execution, privilege escalation and tampering.PLCnext Engineer is using the LibGit2Sharp library to provide version control capabilities.
also known as (4)
Other names and identifiers for this entity.
sources
Which sources assert this record, and when.
references (37)
External citations — patches, advisories, analysis.
- http://lists.opensuse.org/opensuse-security-announce/2020-05/msg00003.htmlcnnvd
- http://www.securityfocus.com/bid/104345cnnvd
- http://www.securitytracker.com/id/1040991cnnvd
- https://access.redhat.com/errata/RHSA-2018:1957cnnvd
- https://access.redhat.com/errata/RHSA-2018:2147cnnvd
- https://blogs.msdn.microsoft.com/devops/2018/05/29/announcing-the-may-2018-git-security-vulnerability/cnnvd
- https://git-scm.com/Patchcnnvd
- https://marc.info/?l=git&m=152761328506724&w=2cnnvd
Attackers weaponise vulnerabilities like this against internet-exposed services. See what is exposed on your perimeter with a free passive scan.
Free scan