CVE-2026-47761
mediumpriority · track · 32EPSS 0.003 · 18 %ileexploit · PoCDEEUFRUSEPSS · scored 2026-10-27
TinyMCE is an open source rich text editor. Prior to 5.11.1, 7.9.3, and 8.5.1, there is a stored XSS vulnerability in the media plugin. Attackers can inject malicious scripts via crafted data-mce-* attributes, which are executed when content is rendered. Impacts users of TinyMCE with the media plugin enabled. This vulnerability is fixed in 5.11.1, 7.9.3, and 8.5.1.
cvss
Technical severity, 0–10. One row per scoring source.
base score 0–10 · higher = more severe · hover a vector to decode⚠ sources disagree · medium–high · 5.1–8.7
ssvc
A stakeholder decision — act, attend, or track — from exploitation and impact.
weaknesses
The CWE weakness classes this flaw belongs to.
exploits (1)
Public proof-of-concept and weaponised exploit code.
- ange-primiterra/CVE-2026-47761ange-primiterra/CVE-2026-47761PoC · poc_in_github
affected products (34)
Products and version ranges known to be affected.
advisories (3)
Vendor and ecosystem advisories describing this.
- WID-SEC-W-2026-3376Atlassian Bamboo, Bitbucket, Confluence, Fisheye/Crucible, Jira Software und Jira Service Management: Mehrere SchwachstellenDeutsch2026-09-15csaf · cert_bundDE
Ein Angreifer kann mehrere Schwachstellen in Atlassian Bamboo, Bitbucket, Confluence, Fisheye/Crucible, Jira Software und Jira Service Management ausnutzen, um beliebigen Programmcode auszuführen, Sicherheitsmaßnahmen zu umgehen, serverseitige Request-Forgery-Angriffe (SSRF) durchzuführen, Cross-Site-Scripting-Angriffe zu starten, sensible Informationen offenzulegen, Daten zu manipulieren oder Denial-of-Service-Zustände herbeizuführen.
- GHSA-vg35-5wq7-3x7wTinyMCE Cross-Site Scripting (XSS) vulnerability using media plugin `data-mce-object` injection2026-06-05ghsa · osvUS
### Impact Stored XSS vulnerability in the media plugin. Attackers can inject malicious scripts via crafted `data-mce-*` attributes, which are executed when content is rendered. Impacts users of TinyMCE with the media plugin enabled. ### Patches This vulnerability has been patched in TinyMCE 8.5.1, TinyMCE 7.9.3 and TinyMCE 5.11.1 LTS by ensuring that, when using the media plugin, any content with `data-mce-object` and `data-mce-p-*` attributes are properly sanitized. ### Workarounds No official workaround available. ### Fix To avoid this vulnerability: - Upgrade to TinyMCE 8.5.1 or higher. - Upgrade to TinyMCE 7.9.3 or higher. - Upgrade to TinyMCE 5.11.1 LTS or higher for TinyMCE 5.x (only available as part of commercial [long-term support](https://www.tiny.cloud/long-term-support/) contract). ### Acknowledgements Tiny thanks [Aymane MAZGUITI](https://github.com/UncleJ4ck) and [Ange Primiterra](https://github.com/ange-primiterra) for their help identifying this vulnerability.
- CERTFR-2026-AVI-1318Multiples vulnérabilités dans MoodleFrançais2026-10-15vendor · certfrFR
also known as (3)
Other names and identifiers for this entity.
sources
Which sources assert this record, and when.
references (10)
External citations — patches, advisories, analysis.
- https://github.com/tinymce/tinymce/security/advisories/GHSA-vg35-5wq7-3x7wcnnvd
- https://github.com/tinymce/tinymce/tagsPatchcnnvd
- https://www.tiny.cloud/docs/tinymce/7/7.9.3-release-notes/#overviewcnnvd
- https://www.tiny.cloud/docs/tinymce/8/8.5.1-release-notes/#overviewcnnvd
- https://github.com/tinymce/tinymce/security/advisories/GHSA-vg35-5wq7-3x7wenisa_euvd
- https://www.tiny.cloud/docs/tinymce/7/7.9.3-release-notes/#overviewenisa_euvd
- https://www.tiny.cloud/docs/tinymce/8/8.5.1-release-notes/#overviewenisa_euvd
- https://github.com/tinymce/tinymce/security/advisories/GHSA-vg35-5wq7-3x7wPatchVendor Advisorynvd
Attackers weaponise vulnerabilities like this against internet-exposed services. See what is exposed on your perimeter with a free passive scan.
Free scan