GHSA-vg35-5wq7-3x7w

ghsaUSosv

TinyMCE Cross-Site Scripting (XSS) vulnerability using media plugin `data-mce-object` injection

view advisory published 2026-06-05Licence: CC-BY-4.0

### Impact Stored XSS vulnerability in the media plugin. Attackers can inject malicious scripts via crafted `data-mce-*` attributes, which are executed when content is rendered. Impacts users of TinyMCE with the media plugin enabled. ### Patches This vulnerability has been patched in TinyMCE 8.5.1, TinyMCE 7.9.3 and TinyMCE 5.11.1 LTS by ensuring that, when using the media plugin, any content with `data-mce-object` and `data-mce-p-*` attributes are properly sanitized. ### Workarounds No official workaround available. ### Fix To avoid this vulnerability: - Upgrade to TinyMCE 8.5.1 or higher. - Upgrade to TinyMCE 7.9.3 or higher. - Upgrade to TinyMCE 5.11.1 LTS or higher for TinyMCE 5.x (only available as part of commercial [long-term support](https://www.tiny.cloud/long-term-support/) contract). ### Acknowledgements Tiny thanks [Aymane MAZGUITI](https://github.com/UncleJ4ck) and [Ange Primiterra](https://github.com/ange-primiterra) for their help identifying this vulnerability.

01

describes (1)

Related CVEs.

IDseverity exploitable
CVE-2026-47761USmedium5.4Exploit
TinyMCE is an open source rich text editor. Prior to 5.11.1, 7.9.3, and 8.5.1, there is a stored XSS vulnerability in the media plugin. Attackers can inject malicious scripts via c…
02

references

External citations — patches, advisories, analysis.

scry

Advisories like this name the exposed products attackers go after on your perimeter. See what is exposed on your perimeter with a free passive scan.

Free scan