CVE-2026-33674
mediumpriority · track · 21EPSS 0.002 · 16 %ileEUUSEPSS · scored 2026-10-27
PrestaShop is an open source e-commerce web application. Versions prior to 8.2.5 and 9.1.0 improperly use the validation framework. Versions 8.2.5 and 9.1.0 contain a fix. No known workarounds are available.
cvss
Technical severity, 0–10. One row per scoring source.
base score 0–10 · higher = more severe · hover a vector to decode⚠ sources disagree · low–medium · 2–5.3
ssvc
A stakeholder decision — act, attend, or track — from exploitation and impact.
weaknesses
The CWE weakness classes this flaw belongs to.
affected products (6)
Products and version ranges known to be affected.
advisories (1)
Vendor and ecosystem advisories describing this.
- GHSA-283w-xf3q-788vPrestaShop: Improper Use of Validation Framework2026-03-25ghsa · osvUS
### Impact Fix improper use of validation framework ### Patches Patched in 8.2.5 and 9.1.0 ### Workarounds None ### References none
also known as (3)
Other names and identifiers for this entity.
sources
Which sources assert this record, and when.
references (10)
External citations — patches, advisories, analysis.
- https://github.com/PrestaShop/PrestaShop/releasesPatchcnnvd
- https://github.com/PrestaShop/PrestaShop/releases/tag/8.2.5cnnvd
- https://github.com/PrestaShop/PrestaShop/releases/tag/9.1.0cnnvd
- https://github.com/PrestaShop/PrestaShop/security/advisories/GHSA-283w-xf3q-788vcnnvd
- https://github.com/PrestaShop/PrestaShop/releases/tag/8.2.5enisa_euvd
- https://github.com/PrestaShop/PrestaShop/releases/tag/9.1.0enisa_euvd
- https://github.com/PrestaShop/PrestaShop/security/advisories/GHSA-283w-xf3q-788venisa_euvd
- https://github.com/PrestaShop/PrestaShop/releases/tag/8.2.5Release Notesnvd
Attackers weaponise vulnerabilities like this against internet-exposed services. See what is exposed on your perimeter with a free passive scan.
Free scan