CVE-2026-23980
mediumpriority · track · 36EPSS 0.007 · 53 %ileexploit · PoCDEEURUUSEPSS · scored 2026-10-27
Improper Neutralization of Special Elements used in a SQL Command ('SQL Injection') vulnerability in Apache Superset allows an authenticated user with read access to conduct error-based SQL injection via the sqlExpression or where parameters. This issue affects Apache Superset: before 6.0.0. Users are recommended to upgrade to version 6.0.0, which fixes the issue.
cvss
Technical severity, 0–10. One row per scoring source.
base score 0–10 · higher = more severe · hover a vector to decode⚠ sources disagree · low–medium · 2.1–6.5
ssvc
A stakeholder decision — act, attend, or track — from exploitation and impact.
weaknesses
The CWE weakness classes this flaw belongs to.
exploits (1)
Public proof-of-concept and weaponised exploit code.
- hyphenTBG/CVE-2026-23980Modified exploit of CVE-2026-23980PoC · poc_in_github
affected products (9)
Products and version ranges known to be affected.
advisories (4)
Vendor and ecosystem advisories describing this.
- WID-SEC-W-2026-0502Apache Superset: Mehrere SchwachstellenDeutsch2026-02-24csaf · cert_bundDE
Ein entfernter, authentisierter Angreifer kann mehrere Schwachstellen in Apache Superset ausnutzen, um Informationen offenzulegen, Daten zu manipulieren oder Sicherheitsmaßnahmen zu umgehen.
- GHSA-gvxg-9hqx-f4rgApache Superset allows privileged users to conduct error-based SQL Injection2026-02-24ghsa · osvUS
Improper Neutralization of Special Elements used in a SQL Command ('SQL Injection') vulnerability in Apache Superset allows an authenticated user with read access to conduct error-based SQL injection via the sqlExpression or where parameters. This issue affects Apache Superset: before 6.0.0. Users are recommended to upgrade to version 6.0.0, which fixes the issue.
- BIT-superset-2026-23980Apache Superset: Improper Neutralization of Special Elements used in a SQL Command2026-02-26vendor · osvUS
Improper Neutralization of Special Elements used in a SQL Command ('SQL Injection') vulnerability in Apache Superset allows an authenticated user with read access to conduct error-based SQL injection via the sqlExpression or where parameters. This issue affects Apache Superset: before 6.0.0. Users are recommended to upgrade to version 6.0.0, which fixes the issue.
- PYSEC-2026-2374Apache Superset allows privileged users to conduct error-based SQL Injection2026-07-13vendor · osvUS
Improper Neutralization of Special Elements used in a SQL Command ('SQL Injection') vulnerability in Apache Superset allows an authenticated user with read access to conduct error-based SQL injection via the sqlExpression or where parameters. This issue affects Apache Superset: before 6.0.0. Users are recommended to upgrade to version 6.0.0, which fixes the issue.
also known as (8)
Other names and identifiers for this entity.
sources
Which sources assert this record, and when.
references (6)
External citations — patches, advisories, analysis.
- http://www.openwall.com/lists/oss-security/2026/02/24/5cnnvd
- https://lists.apache.org/thread/h4l02zw1pr2vywv0dc5zjn3grdcdhwf4cnnvd
- https://superset.apache.org/Patchcnnvd
- https://lists.apache.org/thread/h4l02zw1pr2vywv0dc5zjn3grdcdhwf4enisa_euvd
- http://www.openwall.com/lists/oss-security/2026/02/24/5Mailing ListThird Party Advisorynvd
- https://lists.apache.org/thread/h4l02zw1pr2vywv0dc5zjn3grdcdhwf4Mailing ListVendor Advisorynvd
Attackers weaponise vulnerabilities like this against internet-exposed services. See what is exposed on your perimeter with a free passive scan.
Free scan