PYSEC-2026-2374

vendorUSosv

Apache Superset allows privileged users to conduct error-based SQL Injection

view advisory published 2026-07-13Licence: CC-BY-4.0

Improper Neutralization of Special Elements used in a SQL Command ('SQL Injection') vulnerability in Apache Superset allows an authenticated user with read access to conduct error-based SQL injection via the sqlExpression or where parameters. This issue affects Apache Superset: before 6.0.0. Users are recommended to upgrade to version 6.0.0, which fixes the issue.

01

describes (1)

Related CVEs.

IDseverity exploitable
CVE-2026-23980USmedium6.5Exploit
Improper Neutralization of Special Elements used in a SQL Command ('SQL Injection') vulnerability in Apache Superset allows an authenticated user with read access to conduct error-…
02

references

External citations — patches, advisories, analysis.

scry

Advisories like this name the exposed products attackers go after on your perimeter. See what is exposed on your perimeter with a free passive scan.

Free scan