CVE-2025-27696
highpriority · track · 35OT risk · elevatedEPSS 0.013 · 70 %ileDEEUUSEPSS · scored 2026-10-27
Incorrect Authorization vulnerability in Apache Superset allows ownership takeover of dashboards, charts or datasets by authenticated users with read permissions. This issue affects Apache Superset: through 4.1.1. Users are recommended to upgrade to version 4.1.2 or above, which fixes the issue.
cvss
Technical severity, 0–10. One row per scoring source.
base score 0–10 · higher = more severe · hover a vector to decode⚠ sources disagree · low–high · 1.3–8.8
ssvc
A stakeholder decision — act, attend, or track — from exploitation and impact.
weaknesses
The CWE weakness classes this flaw belongs to.
affected products (6)
Products and version ranges known to be affected.
advisories (4)
Vendor and ecosystem advisories describing this.
- WID-SEC-W-2025-1008Apache Superset: Schwachstelle ermöglicht Umgehung von SicherheitsvorkehrungenDeutsch2025-05-12csaf · cert_bundDE
Ein Angreifer kann eine Schwachstelle in Apache Superset ausnutzen, um Sicherheitsvorkehrungen zu umgehen.
- GHSA-w6c7-j32f-rq8jApache Superset Allows Ownership Takeover2025-05-13ghsa · osvUS
Improper Authorization vulnerability in Apache Superset allows ownership takeover of dashboards, charts or datasets by authenticated users with read permissions. This issue affects Apache Superset: through 4.1.1. Users are recommended to upgrade to version 4.1.2 or above, which fixes the issue.
- BIT-superset-2025-27696Apache Superset: Incorrect authorization leading to resource ownership takeover2025-05-16vendor · osvUS
Incorrect Authorization vulnerability in Apache Superset allows ownership takeover of dashboards, charts or datasets by authenticated users with read permissions. This issue affects Apache Superset: through 4.1.1. Users are recommended to upgrade to version 4.1.2 or above, which fixes the issue.
- PYSEC-2026-1189Apache Superset Allows Ownership Takeover2026-07-07vendor · osvUS
Improper Authorization vulnerability in Apache Superset allows ownership takeover of dashboards, charts or datasets by authenticated users with read permissions. This issue affects Apache Superset: through 4.1.1. Users are recommended to upgrade to version 4.1.2 or above, which fixes the issue.
also known as (7)
Other names and identifiers for this entity.
sources
Which sources assert this record, and when.
references (8)
External citations — patches, advisories, analysis.
- http://www.openwall.com/lists/oss-security/2025/05/12/3cnnvd
- https://access.redhat.com/security/cve/cve-2025-27696cnnvd
- https://lists.apache.org/thread/k2od03bxnxs6vcp80sr03ywcxl194413cnnvd
- https://nvd.nist.gov/vuln/detail/CVE-2025-27696cnnvd
- https://superset.apache.org/Patchcnnvd
- https://lists.apache.org/thread/k2od03bxnxs6vcp80sr03ywcxl194413enisa_euvd
- http://www.openwall.com/lists/oss-security/2025/05/12/3Mailing ListThird Party Advisorynvd
- https://lists.apache.org/thread/k2od03bxnxs6vcp80sr03ywcxl194413Mailing ListVendor Advisorynvd
Attackers weaponise vulnerabilities like this against internet-exposed services. See what is exposed on your perimeter with a free passive scan.
Free scan