Apache Superset Allows Ownership Takeover
Improper Authorization vulnerability in Apache Superset allows ownership takeover of dashboards, charts or datasets by authenticated users with read permissions. This issue affects Apache Superset: through 4.1.1. Users are recommended to upgrade to version 4.1.2 or above, which fixes the issue.
01
describes (1)
Related CVEs.
| ID | severity | exploitable | ||
|---|---|---|---|---|
| CVE-2025-27696US | high8.8OT elevated | — | ||
Incorrect Authorization vulnerability in Apache Superset allows ownership takeover of dashboards, charts or datasets by authenticated users with read permissions.
This issue affec… | ||||
02
references
External citations — patches, advisories, analysis.
- http://www.openwall.com/lists/oss-security/2025/05/12/3WEB
- https://github.com/advisories/GHSA-w6c7-j32f-rq8jADVISORY
- https://github.com/apache/supersetPACKAGE
- https://github.com/apache/superset/commit/fc844d3dfdace890b32c00a507a959b81122b425WEB
- https://lists.apache.org/thread/k2od03bxnxs6vcp80sr03ywcxl194413WEB
- https://nvd.nist.gov/vuln/detail/CVE-2025-27696ADVISORY
- https://pypi.org/project/apache-supersetPACKAGE
scry
Advisories like this name the exposed products attackers go after on your perimeter. See what is exposed on your perimeter with a free passive scan.
Free scan