CVE-2024-51446
mediumpriority · track · 22EPSS 0.003 · 27 %ileDEEUNLRUUSEPSS · scored 2026-10-27
A vulnerability has been identified in Polarion V2310 (All versions), Polarion V2404 (All versions < V2404.4). The file upload feature of the affected application improperly sanitizes xml files. This could allow an authenticated remote attacker to conduct a stored cross-site scripting attack by uploading specially crafted xml files that are later downloaded and viewed by other users of the application.
remediations
Vendor fix, mitigation, or workaround guidance, as published by each source.
A vendor fix is available.
- FixedPolarion V2404siemens_psirt
Update to V2404.4 or later version
https://support.sw.siemens.com/product/230235217/ - FixedPolarion V2404cisa_csaf_ot
Update to V2404.4 or later version
https://support.sw.siemens.com/product/230235217/ - No fix plannedPolarion V2310siemens_psirt
Currently no fix is planned
- No fix plannedPolarion V2310cisa_csaf_ot
Currently no fix is planned
cvss
Technical severity, 0–10. One row per scoring source.
base score 0–10 · higher = more severe · hover a vector to decode⚠ sources disagree · low–medium · 1.2–6.5
ssvc
A stakeholder decision — act, attend, or track — from exploitation and impact.
weaknesses
The CWE weakness classes this flaw belongs to.
affected products (555)
Products and version ranges known to be affected.
advisories (3)
Vendor and ecosystem advisories describing this.
- NCSC-2025-0160Kwetsbaarheden verholpen in Siemens productenNL2025-05-14csaf · ncsc_nlNL
Siemens heeft kwetsbaarheden verholpen in diverse producten als Apogee, BacNet ATEC, Desigo CC, Intralog, OZW, Polarion, RUGGEDCOM, SICAM, SIMATIC, SIPROTEC, SIRIUS, Teamcenter en Versicharge
- SSA-162255SSA-162255: Multiple Vulnerabilities in Polarion Before V24102025-05-13csaf · siemens_psirtDE
Polarion before V2410 contains multiple vulnerabilities that could allow attackers to extract data, conduct cross-site scripting attacks or find out valid usernames. Siemens strongly recommends to update Polarion to V2410 or later versions, not only to fix the documented vulnerabilities, but also to benefit from all the other improvements and fixes. For Polarion V2404 patch releases can be applied.
- ICSA-25-135-11Siemens Polarion2025-05-13icsa · cisa_csaf_otUS
Polarion before V2410 contains multiple vulnerabilities that could allow attackers to extract data, conduct cross-site scripting attacks or find out valid usernames. Siemens strongly recommends to update Polarion to V2410 or later versions, not only to fix the documented vulnerabilities, but also to benefit from all the other improvements and fixes. For Polarion V2404 patch releases can be applied.
also known as (5)
Other names and identifiers for this entity.
sources
Which sources assert this record, and when.
references (3)
External citations — patches, advisories, analysis.
Attackers weaponise vulnerabilities like this against internet-exposed services. See what is exposed on your perimeter with a free passive scan.
Free scan