CVE-2024-38476

criticalpriority · attend · 64EPSS 0.416 · 99 %ileexploit · PoCDEEUNLRUUS
grimoire priorityP1 · Urgent
Exploitable?
Public exploit
1 exploit · PoC
Likely / severe?
41.6% (99th) EPSS
CVSS 9.8 · critical
Is it mine?
141 products
Check your exposure
Who says so?
6 sources
cnnvd · enisa_euvd · fstec_bdu · cert_bund

EPSS · scored 2026-10-22

Vulnerability in core of Apache HTTP Server 2.4.59 and earlier are vulnerably to information disclosure, SSRF or local script execution via backend applications whose response headers are malicious or exploitable. Users are recommended to upgrade to version 2.4.60, which fixes this issue.

01

cvss

Technical severity, 0–10. One row per scoring source.

9.8
010

base score 0–10 · higher = more severe · hover a vector to decode

v3.19.8criticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:Hprimary · NVD / NIST USexploitability 3.9 · impact 5.9
v3.19.8criticalAV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:Hsecondary · FSTEC (BDU) RU
v3.19.8criticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:Hsecondary · ENISA EU
v3.19.8criticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:Hsecondaryexploitability 3.9 · impact 5.9
v3.19.8criticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H/E:Hsecondary · CVSS-BT (t0sche)
v3.19.8criticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:Hsecondary · NCSC-NL NL
02

ssvc

A stakeholder decision — act, attend, or track — from exploitation and impact.

Exploitation: none · Automatable: yes · Technical Impact: totalcoordinatorcisa_ssvcUS
03

weaknesses

The CWE weakness classes this flaw belongs to.

04

exploits (1)

Public proof-of-concept and weaponised exploit code.

05

affected products (141)

Products and version ranges known to be affected.

showing 20 of 141
06

advisories (9)

Vendor and ecosystem advisories describing this.

  • NCSC-2024-0275Kwetsbaarheden verholpen in Apache HHTP-serverNL2024-07-02csaf · ncsc_nlNL

    Apache Software Foundation heeft kwetsbaarheden verholpen in de Apache HTTP-Server.

  • NCSC-2024-0411Kwetsbaarheden verholpen in Oracle Database productenNL2024-10-17csaf · ncsc_nlNL

    Oracle heeft kwetsbaarheden verholpen in diverse Database producten en subsystemen, zoals de Core database, Application Express, Autonomous Health Framework, Essbase, GoldenGate, SQL Developer en Secure Backup.

  • NCSC-2024-0426Kwetsbaarheden verholpen in Apple MacOSNL2024-10-30csaf · ncsc_nlNL

    Apple heeft kwetsbaarheden verholpen in MacOS.

  • NCSC-2025-0128Kwetsbaarheden verholpen in Oracle Fusion MiddlewareNL2025-04-16csaf · ncsc_nlNL

    Oracle heeft meerdere kwetsbaarheden verholpen in verschillende producten, waaronder de Utilities Application Framework, WebLogic Server, en Fusion Middleware.

  • WID-SEC-W-2024-1504Apache HTTP Server: Mehrere SchwachstellenDeutsch2024-07-01csaf · cert_bundDE

    Ein entfernter, anonymer Angreifer kann mehrere Schwachstellen in Apache HTTP Server ausnutzen, um beliebigen Code auszuführen, einen Denial-of-Service-Zustand herbeizuführen, Sicherheitsmaßnahmen zu umgehen oder vertrauliche Informationen offenzulegen.

  • WID-SEC-W-2024-3199Oracle Secure Backup: Mehrere SchwachstellenDeutsch2024-10-15csaf · cert_bundDE

    Ein entfernter, anonymer Angreifer kann mehrere Schwachstellen in Oracle Secure Backup ausnutzen, um die Verfügbarkeit zu gefährden.

  • WID-SEC-W-2024-3291Apple macOS: Mehrere SchwachstellenDeutsch2024-10-28csaf · cert_bundDE

    Ein entfernter, anonymer Angreifer kann mehrere Schwachstellen in Apple macOS ausnutzen, um einen Denial of Service Angriff durchzuführen.

  • WID-SEC-W-2025-0818Oracle Fusion Middleware: Mehrere SchwachstellenDeutsch2025-04-15csaf · cert_bundDE

    Ein entfernter, anonymer oder authentisierter Angreifer kann mehrere Schwachstellen in Oracle Fusion Middleware ausnutzen, um die Vertraulichkeit, Integrität und Verfügbarkeit zu gefährden.

  • BIT-apache-2024-38476Apache HTTP Server may use exploitable/malicious backend application output to run local handlers via internal redirect2024-07-03vendor · osvUS

    Vulnerability in core of Apache HTTP Server 2.4.59 and earlier are vulnerably to information disclosure, SSRF or local script execution via backend applications whose response headers are malicious or exploitable. Users are recommended to upgrade to version 2.4.60, which fixes this issue.

07

also known as (4)

Other names and identifiers for this entity.

08

sources

Which sources assert this record, and when.

09

references (13)

External citations — patches, advisories, analysis.

scry

Attackers weaponise vulnerabilities like this against internet-exposed services. See what is exposed on your perimeter with a free passive scan.

Free scan