CVE-2023-49736
highpriority · track · 35EPSS 0.012 · 68 %ileDEEUUSEPSS · scored 2026-10-27
A where_in JINJA macro allows users to specify a quote, which combined with a carefully crafted statement would allow for SQL injection in Apache Superset.This issue affects Apache Superset: before 2.1.2, from 3.0.0 before 3.0.2. Users are recommended to upgrade to version 3.0.2, which fixes the issue.
cvss
Technical severity, 0–10. One row per scoring source.
base score 0–10 · higher = more severe · hover a vector to decode⚠ sources disagree · medium–high · 6.5–8.8
weaknesses
The CWE weakness classes this flaw belongs to.
affected products (8)
Products and version ranges known to be affected.
advisories (4)
Vendor and ecosystem advisories describing this.
- WID-SEC-W-2023-3184Apache Superset: Mehrere SchwachstellenDeutsch2023-12-19csaf · cert_bundDE
Ein Angreifer kann mehrere Schwachstellen in Apache Superset ausnutzen, um einen Denial of Service zu verursachen, Sicherheitseinstellungen zu umgehen und einen SQL-Injection Angriff durchzuführen.
- GHSA-jfxj-xf67-x723Apache Superset SQL injection vulnerability2023-12-19ghsa · osvUS
A where_in JINJA macro allows users to specify a quote, which combined with a carefully crafted statement would allow for SQL injection in Apache Superset.This issue affects Apache Superset: before 2.1.3, from 3.0.0 before 3.0.2. Users are recommended to upgrade to version 2.1.3 or 3.0.2, which fixes the issue.
- BIT-superset-2023-49736Apache Superset: SQL Injection on where_in JINJA macro2025-02-05vendor · osvUS
A where_in JINJA macro allows users to specify a quote, which combined with a carefully crafted statement would allow for SQL injection in Apache Superset.This issue affects Apache Superset: before 2.1.2, from 3.0.0 before 3.0.2. Users are recommended to upgrade to version 3.0.2, which fixes the issue.
- PYSEC-2026-1184Apache Superset SQL injection vulnerability2026-07-07vendor · osvUS
A where_in JINJA macro allows users to specify a quote, which combined with a carefully crafted statement would allow for SQL injection in Apache Superset.This issue affects Apache Superset: before 2.1.3, from 3.0.0 before 3.0.2. Users are recommended to upgrade to version 2.1.3 or 3.0.2, which fixes the issue.
also known as (7)
Other names and identifiers for this entity.
sources
Which sources assert this record, and when.
references (8)
External citations — patches, advisories, analysis.
- http://www.openwall.com/lists/oss-security/2023/12/19/2cnnvd
- https://cxsecurity.com/cveshow/CVE-2023-49736/cnnvd
- https://lists.apache.org/thread/1kf481bgs3451qcz6hfhobs7xvhp8n1pcnnvd
- https://nvd.nist.gov/vuln/detail/CVE-2023-49736cnnvd
- http://www.openwall.com/lists/oss-security/2023/12/19/2enisa_euvd
- https://lists.apache.org/thread/1kf481bgs3451qcz6hfhobs7xvhp8n1penisa_euvd
- http://www.openwall.com/lists/oss-security/2023/12/19/2Mailing ListThird Party Advisorynvd
- https://lists.apache.org/thread/1kf481bgs3451qcz6hfhobs7xvhp8n1pMailing ListVendor Advisorynvd
Attackers weaponise vulnerabilities like this against internet-exposed services. See what is exposed on your perimeter with a free passive scan.
Free scan