Apache Superset SQL injection vulnerability
A where_in JINJA macro allows users to specify a quote, which combined with a carefully crafted statement would allow for SQL injection in Apache Superset.This issue affects Apache Superset: before 2.1.3, from 3.0.0 before 3.0.2. Users are recommended to upgrade to version 2.1.3 or 3.0.2, which fixes the issue.
01
describes (1)
Related CVEs.
| ID | severity | exploitable | ||
|---|---|---|---|---|
| CVE-2023-49736US | high8.8 | — | ||
A where_in JINJA macro allows users to specify a quote, which combined with a carefully crafted statement would allow for SQL injection in Apache Superset.This issue affects Apache… | ||||
02
references
External citations — patches, advisories, analysis.
- http://www.openwall.com/lists/oss-security/2023/12/19/2WEB
- https://github.com/apache/supersetPACKAGE
- https://github.com/apache/superset/commit/1d403dab9822a8cee6108669c53e53fad881c751WEB
- https://github.com/apache/superset/commit/34101594e284ab3acce692f41aff7759ccb4bf1dWEB
- https://github.com/apache/superset/pull/25779WEB
- https://lists.apache.org/thread/1kf481bgs3451qcz6hfhobs7xvhp8n1pWEB
- https://nvd.nist.gov/vuln/detail/CVE-2023-49736ADVISORY
scry
Advisories like this name the exposed products attackers go after on your perimeter. See what is exposed on your perimeter with a free passive scan.
Free scan