CVE-2021-41164

lowpriority · track · 22EPSS 0.013 · 71 %ileEURUUS
grimoire priorityP3 · Track
Exploitable?
—
no known exploitation
Likely / severe?
1.35% (71st) EPSS
CVSS 3.5 · low
Is it mine?
48 products
Check your exposure
Who says so?
4 sources
cnnvd · enisa_euvd · fstec_bdu · osv

EPSS · scored 2026-10-27

CKEditor4 is an open source WYSIWYG HTML editor. In affected versions a vulnerability has been discovered in the Advanced Content Filter (ACF) module and may affect all plugins used by CKEditor 4. The vulnerability allowed to inject malformed HTML bypassing content sanitization, which could result in executing JavaScript code. It affects all users using the CKEditor 4 at version < 4.17.0. The problem has been recognized and patched. The fix will be available in version 4.17.0.

01

cvss

Technical severity, 0–10. One row per scoring source.

8.2
010

base score 0–10 · higher = more severe · hover a vector to decode⚠ sources disagree · low–high · 3.5–8.2

v2.03.5lowAV:N/AC:M/Au:S/C:N/I:P/A:Nprimary · NVD / NIST USexploitability 6.8 · impact 2.9
v3.15.4mediumCVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:Nprimary · NVD / NIST USexploitability 2.3 · impact 2.7
v3.15.4mediumAV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:Nsecondary · FSTEC (BDU) RU
v3.18.2highCVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:L/A:Lsecondary · ENISA EU
v3.18.2highCVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:L/A:Lsecondary · security-advisories@github.comexploitability 2.3 · impact 5.3
v3.18.2highCVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:L/A:Lsecondary · OSV
v3.15mediumCVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N/E:Usecondary · CVSS-BT (t0sche)
02

weaknesses

The CWE weakness classes this flaw belongs to.

03

affected products (48)

Products and version ranges known to be affected.

showing 20 of 48
04

advisories (2)

Vendor and ecosystem advisories describing this.

  • GHSA-pvmx-g8h5-cprjAdvanced Content Filter (ACF) vulnerability allowing to execute JavaScript code using malformed HTML2021-11-17ghsa · osvUS

    ### Affected packages The vulnerability has been discovered in the Advanced Content Filter (ACF) module and may affect all plugins used by CKEditor 4. ### Impact A potential vulnerability has been discovered in CKEditor 4 Advanced Content Filter (ACF) core module. The vulnerability allowed to inject malformed HTML bypassing content sanitization, which could result in executing JavaScript code. It affects all users using the CKEditor 4 at version < 4.17.0. ### Patches The problem has been recognized and patched. The fix will be available in version 4.17.0. ### For more information Email us at security@cksource.com if you have any questions or comments about this advisory. ### Acknowledgements The CKEditor 4 team would like to thank Maurice Dauer ([laytonctf](https://twitter.com/laytonctf)) for recognizing and reporting this vulnerability.

  • BIT-drupal-2021-41164Advanced Content Filter (ACF) vulnerability allowing to execute JavaScript code using malformed HTML2024-03-06vendor · osvUS

    CKEditor4 is an open source WYSIWYG HTML editor. In affected versions a vulnerability has been discovered in the Advanced Content Filter (ACF) module and may affect all plugins used by CKEditor 4. The vulnerability allowed to inject malformed HTML bypassing content sanitization, which could result in executing JavaScript code. It affects all users using the CKEditor 4 at version < 4.17.0. The problem has been recognized and patched. The fix will be available in version 4.17.0.

05

also known as (6)

Other names and identifiers for this entity.

06

sources

Which sources assert this record, and when.

published 2021-11-17modified 2026-06-17
08

references (25)

External citations — patches, advisories, analysis.

scry

Attackers weaponise vulnerabilities like this against internet-exposed services. See what is exposed on your perimeter with a free passive scan.

Free scan