GHSA-pvmx-g8h5-cprj

ghsaUSosv

Advanced Content Filter (ACF) vulnerability allowing to execute JavaScript code using malformed HTML

view advisory published 2021-11-17Licence: CC-BY-4.0

### Affected packages The vulnerability has been discovered in the Advanced Content Filter (ACF) module and may affect all plugins used by CKEditor 4. ### Impact A potential vulnerability has been discovered in CKEditor 4 Advanced Content Filter (ACF) core module. The vulnerability allowed to inject malformed HTML bypassing content sanitization, which could result in executing JavaScript code. It affects all users using the CKEditor 4 at version < 4.17.0. ### Patches The problem has been recognized and patched. The fix will be available in version 4.17.0. ### For more information Email us at security@cksource.com if you have any questions or comments about this advisory. ### Acknowledgements The CKEditor 4 team would like to thank Maurice Dauer ([laytonctf](https://twitter.com/laytonctf)) for recognizing and reporting this vulnerability.

01

describes (1)

Related CVEs.

IDseverity exploitable
CVE-2021-41164USmedium5.4—
CKEditor4 is an open source WYSIWYG HTML editor. In affected versions a vulnerability has been discovered in the Advanced Content Filter (ACF) module and may affect all plugins use…
02

references

External citations — patches, advisories, analysis.

scry

Advisories like this name the exposed products attackers go after on your perimeter. See what is exposed on your perimeter with a free passive scan.

Free scan