CVE-2019-5786

mediumpriority · act · 90OT risk · criticalKEV · exploitedEPSS 0.611 · 99 %ileexploit · functionalEURUUS
grimoire priorityP0 · Act now
Exploitable?
Yes · in the wild
CISA KEV · 3 exploits · functional
Likely / severe?
61.1% (99th) EPSS
CVSS 4.3 · medium
Is it mine?
7 products
Check your exposure
Who says so?
5 sources
cnnvd · enisa_euvd · fstec_bdu · nvd

added 2022-05-23remediate by 2022-06-13

required action Apply updates per vendor instructions.

EPSS · scored 2026-10-27

Google Chrome Blink Use-After-Free Vulnerability

Object lifetime issue in Blink in Google Chrome prior to 72.0.3626.121 allowed a remote attacker to potentially perform out of bounds memory access via a crafted HTML page.

01

cvss

Technical severity, 0–10. One row per scoring source.

9.6
010

base score 0–10 · higher = more severe · hover a vector to decode⚠ sources disagree · medium–critical · 4.3–9.6

v2.04.3mediumAV:N/AC:M/Au:N/C:N/I:N/A:Pprimary · NVD / NIST USexploitability 8.6 · impact 2.9
v3.16.5mediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:Hprimary · NVD / NIST USexploitability 2.8 · impact 3.6
v3.06.5mediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:Hsecondary · OSV
v3.16.5mediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H/E:Hsecondary · CVSS-BT (t0sche)
v3.16.5mediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:Hsecondary · ENISA EU
v3.19.6criticalAV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:Hsecondary · FSTEC (BDU) RU
v3.16.5mediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:Hsecondaryexploitability 2.8 · impact 3.6
02

ssvc

A stakeholder decision — act, attend, or track — from exploitation and impact.

Exploitation: active · Automatable: no · Technical Impact: partialcoordinatorcisa_ssvcUS
03

weaknesses

The CWE weakness classes this flaw belongs to.

04

exploits (3)

Public proof-of-concept and weaponised exploit code.

05

affected products (7)

Products and version ranges known to be affected.

06

advisories (1)

Vendor and ecosystem advisories describing this.

  • GHSA-c2gp-86p4-5935Use-After-Free in puppeteer2020-09-02ghsa · osvUS

    Versions of `puppeteer` prior to 1.13.0 are vulnerable to the Use-After-Free vulnerability in Chromium (CVE-2019-5786). The Chromium FileReader API is vulnerable to Use-After-Free which may lead to Remote Code Execution. ## Recommendation Upgrade to version 1.13.0 or later.

07

also known as (4)

Other names and identifiers for this entity.

08

sources

Which sources assert this record, and when.

published 2019-06-27modified 2026-06-17
10

references (24)

External citations — patches, advisories, analysis.

scry

Attackers weaponise vulnerabilities like this against internet-exposed services. See what is exposed on your perimeter with a free passive scan.

Free scan