GHSA-c2gp-86p4-5935

ghsaUSosv

Use-After-Free in puppeteer

view advisory published 2020-09-02Licence: CC-BY-4.0

Versions of `puppeteer` prior to 1.13.0 are vulnerable to the Use-After-Free vulnerability in Chromium (CVE-2019-5786). The Chromium FileReader API is vulnerable to Use-After-Free which may lead to Remote Code Execution. ## Recommendation Upgrade to version 1.13.0 or later.

01

describes (1)

Related CVEs.

IDseverity exploitable
CVE-2019-5786USmedium6.5OT criticalKEV
Object lifetime issue in Blink in Google Chrome prior to 72.0.3626.121 allowed a remote attacker to potentially perform out of bounds memory access via a crafted HTML page.
02

references

External citations — patches, advisories, analysis.

scry

Advisories like this name the exposed products attackers go after on your perimeter. See what is exposed on your perimeter with a free passive scan.

Free scan