CVE-2019-20921
mediumpriority · track · 25EPSS 0.017 · 78 %ileDEEUUSEPSS · scored 2026-10-27
bootstrap-select before 1.13.6 allows Cross-Site Scripting (XSS). It does not escape title values in OPTION elements. This may allow attackers to execute arbitrary JavaScript in a victim's browser.
remediations
Vendor fix, mitigation, or workaround guidance, as published by each source.
A vendor fix is available.
- Fixedovirt-web-ui-0:1.6.7-1.el8ev.noarch as a component of RHEL-8-RHEV-S-4.4 - Red Hat Virtualization Engine 4.4redhat_csaf
For details on how to apply this update, which includes the changes described in this advisory, refer to: https://access.redhat.com/articles/2974891
https://access.redhat.com/errata/RHSA-2021:1169 - Fixedovirt-web-ui-0:1.6.7-1.el8ev.src as a component of RHEL-8-RHEV-S-4.4 - Red Hat Virtualization Engine 4.4redhat_csaf
For details on how to apply this update, which includes the changes described in this advisory, refer to: https://access.redhat.com/articles/2974891
https://access.redhat.com/errata/RHSA-2021:1169 - Fixedovirt-engine-ui-extensions-0:1.2.5-1.el8ev.noarch as a component of RHEL-8-RHEV-S-4.4 - Red Hat Virtualization Engine 4.4redhat_csaf
For details on how to apply this update, which includes the changes described in this advisory, refer to: https://access.redhat.com/articles/2974891
https://access.redhat.com/errata/RHSA-2021:1186 - Fixedovirt-engine-ui-extensions-0:1.2.5-1.el8ev.src as a component of RHEL-8-RHEV-S-4.4 - Red Hat Virtualization Engine 4.4redhat_csaf
For details on how to apply this update, which includes the changes described in this advisory, refer to: https://access.redhat.com/articles/2974891
https://access.redhat.com/errata/RHSA-2021:1186
cvss
Technical severity, 0–10. One row per scoring source.
base score 0–10 · higher = more severe · hover a vector to decode
weaknesses
The CWE weakness classes this flaw belongs to.
affected products (45)
Products and version ranges known to be affected.
- IBM Tivoli Network Manager IP Edition 4.2all versionscert_bundDEcpe:/a:ibm:tivoli_network_manager:ip_edition_4.2
- snapappointments bootstrap-select< 1.13.6nvdUScpe:2.3:a:snapappointments:bootstrap-select:*:*:*:*:*:*:*:*
advisories (5)
Vendor and ecosystem advisories describing this.
- RHSA-2021:1169Red Hat Security Advisory: RHV Manager (ovirt-engine) 4.4.z [ovirt-4.4.5] security, bug fix, enhancement2021-04-14csaf · redhat_csafUS
An update is now available for Red Hat Virtualization Engine 4.4. Red Hat Product Security has rated this update as having a security impact of Moderate. A Common Vulnerability Scoring System (CVSS) base score, which gives a detailed severity rating, is available for each vulnerability from the CVE link(s) in the References section.
- RHSA-2021:1186Red Hat Security Advisory: RHV Manager (ovirt-engine) 4.4.z [ovirt-4.4.5] 0-day security, bug fix, enhance2021-04-14csaf · redhat_csafUS
An update for org.ovirt.engine-root, ovirt-engine-ui-extensions, and ovirt-web-ui is now available for Red Hat Virtualization Engine 4.4. Red Hat Product Security has rated this update as having a security impact of Moderate. A Common Vulnerability Scoring System (CVSS) base score, which gives a detailed severity rating, is available for each vulnerability from the CVE link(s) in the References section.
- WID-SEC-W-2022-0808Red Hat Virtualization Engine: Mehrere SchwachstellenDeutsch2021-04-14csaf · cert_bundDE
Ein entfernter, anonymer Angreifer kann mehrere Schwachstellen in der Red Hat Virtualization Engine ausnutzen, um einen Cross-Site Scripting Angriff durchzuführen, beliebigen Code auszuführen, einen Denial of Service Zustand auszulösen und kryptographische Maßnahmen zu umgehen.
- GHSA-7c82-mp33-r854Cross-site scripting in bootstrap-select2021-05-07ghsa · osvUS
bootstrap-select before 1.13.6 allows Cross-Site Scripting (XSS). It does not escape title values in OPTION elements. This may allow attackers to execute arbitrary JavaScript in a victim's browser.
- GHSA-9r7h-6639-v5mwCross-Site Scripting in bootstrap-select2020-09-03ghsa · osvUS
Versions of `bootstrap-select` prior to 1.13.6 are vulnerable to Cross-Site Scripting (XSS). The package does not escape `title` values on `<option>` tags. This may allow attackers to execute arbitrary JavaScript in a victim's browser. ## Recommendation Upgrade to version 1.13.6 or later.
also known as (6)
Other names and identifiers for this entity.
sources
Which sources assert this record, and when.
references (18)
External citations — patches, advisories, analysis.
- https://github.com/advisories/GHSA-9r7h-6639-v5mwcnnvd
- https://github.com/snapappointments/bootstrap-select/issues/2199cnnvd
- https://nvd.nist.gov/vuln/detail/CVE-2019-20921cnnvd
- https://packetstormsecurity.com/files/162171/Red-Hat-Security-Advisory-2021-1186-01.htmlcnnvd
- https://snyk.io/vuln/SNYK-JS-BOOTSTRAPSELECT-570457cnnvd
- https://vigilance.fr/vulnerability/Node-js-bootstrap-select-Cross-Site-Scripting-35331cnnvd
- https://www.auscert.org.au/bulletins/ESB-2021.1274cnnvd
- https://www.npmjs.com/advisories/1522cnnvd
Attackers weaponise vulnerabilities like this against internet-exposed services. See what is exposed on your perimeter with a free passive scan.
Free scan