CVE-2019-14858

lowpriority · track · 22EPSS 0.004 · 36 %ileDEEURUUS
grimoire priorityP3 · Track
Exploitable?
—
no known exploitation
Likely / severe?
0.42% (36th) EPSS
CVSS 2.1 · low
Is it mine?
34 products
Check your exposure
Who says so?
7 sources
cnnvd · enisa_euvd · fstec_bdu · osv

EPSS · scored 2026-10-27

A vulnerability was found in Ansible engine 2.x up to 2.8 and Ansible tower 3.x up to 3.5. When a module has an argument_spec with sub parameters marked as no_log, passing an invalid parameter name to the module will cause the task to fail before the no_log options in the sub parameters are processed. As a result, data in the sub parameter fields will not be masked and will be displayed if Ansible is run with increased verbosity and present in the module invocation arguments for the task.

01

remediations

Vendor fix, mitigation, or workaround guidance, as published by each source.

A vendor fix is available.

02

cvss

Technical severity, 0–10. One row per scoring source.

7.3
010

base score 0–10 · higher = more severe · hover a vector to decode⚠ sources disagree · low–high · 2.1–7.3

v2.02.1lowAV:L/AC:L/Au:N/C:P/I:N/A:Nprimary · NVD / NIST USexploitability 3.9 · impact 2.9
v3.15.5mediumCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:Nprimary · NVD / NIST USexploitability 1.8 · impact 3.6
v3.07.3highCVSS:3.0/AV:L/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:Hsecondary · secalert@redhat.com USexploitability 1.3 · impact 5.9
v3.07.3highCVSS:3.0/AV:L/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:Hsecondary · ENISA EU
v3.17.3highAV:L/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:Hsecondary · FSTEC (BDU) RU
v3.15.5mediumCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:Nsecondary · OSV
v3.15.1mediumCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N/E:Usecondary · CVSS-BT (t0sche)
v3.15mediumCVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:H/I:N/A:Nsecondary · Red Hat Product Security US
03

weaknesses

The CWE weakness classes this flaw belongs to.

04

affected products (34)

Products and version ranges known to be affected.

showing 20 of 34
05

advisories (7)

Vendor and ecosystem advisories describing this.

  • RHSA-2019:3202Red Hat Security Advisory: Ansible security and bug fix update2019-10-24csaf · redhat_csafUS

    An update is now available for Ansible Engine 2.7. Red Hat Product Security has rated this update as having a security impact of Important. A Common Vulnerability Scoring System (CVSS) base score, which gives a detailed severity rating, is available for each vulnerability from the CVE link(s) in the References section.

  • RHSA-2019:3203Red Hat Security Advisory: Ansible security and bug fix update2019-10-24csaf · redhat_csafUS

    An update is now available for Ansible Engine 2.8. Red Hat Product Security has rated this update as having a security impact of Important. A Common Vulnerability Scoring System (CVSS) base score, which gives a detailed severity rating, is available for each vulnerability from the CVE link(s) in the References section.

  • RHSA-2019:3207Red Hat Security Advisory: Ansible security and bug fix update2019-10-24csaf · redhat_csafUS

    An update is now available for Ansible Engine 2. Red Hat Product Security has rated this update as having a security impact of Important. A Common Vulnerability Scoring System (CVSS) base score, which gives a detailed severity rating, is available for each vulnerability from the CVE link(s) in the References section.

  • RHSA-2020:0756Red Hat Security Advisory: ansible security update2020-03-10csaf · redhat_csafUS

    An update for ansible is now available for Red Hat OpenStack Platform 13.0 (Queens) for RHEL 7. Red Hat Product Security has rated this update as having a security impact of Moderate. A Common Vulnerability Scoring System (CVSS) base score, which gives a detailed severity rating, is available for each vulnerability from the CVE link(s) in the References section.

  • WID-SEC-W-2024-3593Ansible: Schwachstelle ermöglicht Offenlegung von InformationenDeutsch2019-10-14csaf · cert_bundDE

    Ein lokaler Angreifer kann eine Schwachstelle in Ansible ausnutzen, um Informationen offenzulegen.

  • GHSA-h653-95qw-h2mpAnsible leaks sensitive information to logs when told not to2022-05-24ghsa · osvUS

    A vulnerability was found in Ansible engine 2.x up to 2.8 and Ansible tower 3.x up to 3.5. When a module has an argument_spec with sub parameters marked as `no_log`, passing an invalid parameter name to the module will cause the task to fail before the `no_log` options in the sub parameters are processed. As a result, data in the sub parameter fields will not be masked and will be displayed if Ansible is run with increased verbosity and present in the module invocation arguments for the task.

  • PYSEC-2019-1712019-10-14vendor · osvUS

    A vulnerability was found in Ansible engine 2.x up to 2.8 and Ansible tower 3.x up to 3.5. When a module has an argument_spec with sub parameters marked as no_log, passing an invalid parameter name to the module will cause the task to fail before the no_log options in the sub parameters are processed. As a result, data in the sub parameter fields will not be masked and will be displayed if Ansible is run with increased verbosity and present in the module invocation arguments for the task.

06

also known as (7)

Other names and identifiers for this entity.

07

sources

Which sources assert this record, and when.

09

references (28)

External citations — patches, advisories, analysis.

scry

Attackers weaponise vulnerabilities like this against internet-exposed services. See what is exposed on your perimeter with a free passive scan.

Free scan