Red Hat Security Advisory: Ansible security and bug fix update
An update is now available for Ansible Engine 2.7. Red Hat Product Security has rated this update as having a security impact of Important. A Common Vulnerability Scoring System (CVSS) base score, which gives a detailed severity rating, is available for each vulnerability from the CVE link(s) in the References section.
describes (3)
Related CVEs.
| ID | severity | exploitable | ||
|---|---|---|---|---|
| CVE-2019-14856US | medium6.5 | — | ||
ansible before versions 2.8.6, 2.7.14, 2.6.20 is vulnerable to a None | ||||
| CVE-2019-14858US | medium5.5 | — | ||
A vulnerability was found in Ansible engine 2.x up to 2.8 and Ansible tower 3.x up to 3.5. When a module has an argument_spec with sub parameters marked as no_log, passing an inval… | ||||
| CVE-2019-14846US | high7.8 | — | ||
In Ansible, all Ansible Engine versions up to ansible-engine 2.8.5, ansible-engine 2.7.13, ansible-engine 2.6.19, were logging at the DEBUG level which lead to a disclosure of cred… | ||||
references
External citations — patches, advisories, analysis.
remediations (8)
- Fixedansible-0:2.7.14-1.el7ae.noarch as a component of Red Hat Ansible Engine 2.7 for RHEL 7 Server
For details on how to apply this update, which includes the changes described in this advisory, refer to: https://access.redhat.com/articles/11258
https://access.redhat.com/errata/RHSA-2019:3202 - Fixedansible-0:2.7.14-1.el7ae.noarch as a component of Red Hat Ansible Engine 2.7 for RHEL 7 Server
For details on how to apply this update, which includes the changes described in this advisory, refer to: https://access.redhat.com/articles/11258
https://access.redhat.com/errata/RHSA-2019:3202 - Fixedansible-0:2.7.14-1.el7ae.noarch as a component of Red Hat Ansible Engine 2.7 for RHEL 7 Server
For details on how to apply this update, which includes the changes described in this advisory, refer to: https://access.redhat.com/articles/11258
https://access.redhat.com/errata/RHSA-2019:3202 - Fixedansible-0:2.7.14-1.el7ae.src as a component of Red Hat Ansible Engine 2.7 for RHEL 7 Server
For details on how to apply this update, which includes the changes described in this advisory, refer to: https://access.redhat.com/articles/11258
https://access.redhat.com/errata/RHSA-2019:3202 - Fixedansible-0:2.7.14-1.el7ae.src as a component of Red Hat Ansible Engine 2.7 for RHEL 7 Server
For details on how to apply this update, which includes the changes described in this advisory, refer to: https://access.redhat.com/articles/11258
https://access.redhat.com/errata/RHSA-2019:3202 - Fixedansible-0:2.7.14-1.el7ae.src as a component of Red Hat Ansible Engine 2.7 for RHEL 7 Server
For details on how to apply this update, which includes the changes described in this advisory, refer to: https://access.redhat.com/articles/11258
https://access.redhat.com/errata/RHSA-2019:3202 - Workaroundansible-0:2.7.14-1.el7ae.noarch as a component of Red Hat Ansible Engine 2.7 for RHEL 7 Server
Mitigation for this issue is either not available or the currently available options don't meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base or stability.
- Workaroundansible-0:2.7.14-1.el7ae.src as a component of Red Hat Ansible Engine 2.7 for RHEL 7 Server
Mitigation for this issue is either not available or the currently available options don't meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base or stability.
Advisories like this name the exposed products attackers go after on your perimeter. See what is exposed on your perimeter with a free passive scan.
Free scan