CVE-2019-11069
mediumpriority · track · 31EPSS 0.018 · 79 %ileEUUSEPSS · scored 2026-10-27
Sequelize version 5 before 5.3.0 does not properly ensure that standard conforming strings are used.
cvss
Technical severity, 0–10. One row per scoring source.
base score 0–10 · higher = more severe · hover a vector to decode⚠ sources disagree · medium–high · 5–7.5
weaknesses
The CWE weakness classes this flaw belongs to.
affected products (3)
Products and version ranges known to be affected.
advisories (1)
Vendor and ecosystem advisories describing this.
- GHSA-2777-2vq8-c4v4SQL Injection in sequelize2019-04-11ghsa · osvUS
Versions of `sequelize` prior to 5.3.0 (excluding v3 and v4) are vulnerable to SQL Injection. PostgreSQL option`standard_conforming_strings` is not set to `on` by default, which may allow attackers to inject SQL statements due to poor handling of backslashes in string literals. ## Recommendation Upgrade to version 5.3.0 or later.
also known as (3)
Other names and identifiers for this entity.
sources
Which sources assert this record, and when.
references (12)
External citations — patches, advisories, analysis.
- https://github.com/sequelize/sequelize/blob/98cb17c17f73e2aa1792aa5a1d31216ba984b456/lib/dialects/postgres/connection-manager.js#L158-L160cnnvd
- https://github.com/sequelize/sequelize/pull/10746/filescnnvd
- https://github.com/sequelize/sequelize/releases/tag/v5.3.0cnnvd
- https://nvd.nist.gov/vuln/detail/CVE-2019-11069cnnvd
- https://github.com/sequelize/sequelize/blob/98cb17c17f73e2aa1792aa5a1d31216ba984b456/lib/dialects/postgres/connection-manager.js#L158-L160enisa_euvd
- https://github.com/sequelize/sequelize/commit/850c7fd04669e0fef9238b6dc4f8d6ee93ed71e9enisa_euvd
- https://github.com/sequelize/sequelize/pull/10746/filesenisa_euvd
- https://github.com/sequelize/sequelize/releases/tag/v5.3.0enisa_euvd
Attackers weaponise vulnerabilities like this against internet-exposed services. See what is exposed on your perimeter with a free passive scan.
Free scan