GHSA-2777-2vq8-c4v4

ghsaUSosv

SQL Injection in sequelize

view advisory published 2019-04-11Licence: CC-BY-4.0

Versions of `sequelize` prior to 5.3.0 (excluding v3 and v4) are vulnerable to SQL Injection. PostgreSQL option`standard_conforming_strings` is not set to `on` by default, which may allow attackers to inject SQL statements due to poor handling of backslashes in string literals. ## Recommendation Upgrade to version 5.3.0 or later.

01

describes (1)

Related CVEs.

IDseverity exploitable
CVE-2019-11069UShigh7.5—
Sequelize version 5 before 5.3.0 does not properly ensure that standard conforming strings are used.
02

references

External citations — patches, advisories, analysis.

scry

Advisories like this name the exposed products attackers go after on your perimeter. See what is exposed on your perimeter with a free passive scan.

Free scan