CVE-2019-10749
highpriority · track · 39EPSS 0.012 · 69 %ileEUUSEPSS · scored 2026-10-27
sequelize before version 3.35.1 allows attackers to perform a SQL Injection due to the JSON path keys not being properly sanitized in the Postgres dialect.
cvss
Technical severity, 0–10. One row per scoring source.
base score 0–10 · higher = more severe · hover a vector to decode⚠ sources disagree · high–critical · 7.5–9.8
weaknesses
The CWE weakness classes this flaw belongs to.
affected products (3)
Products and version ranges known to be affected.
advisories (1)
Vendor and ecosystem advisories describing this.
- GHSA-2598-2f59-rmhqSQL Injection in sequelize2019-11-08ghsa · osvUS
Versions of `sequelize` prior to 3.35.1 are vulnerable to SQL Injection. The package fails to sanitize JSON path keys in the Postgres dialect, which may allow attackers to inject SQL statements and execute arbitrary SQL queries. ## Recommendation Upgrade to version 3.35.1 or later.
also known as (4)
Other names and identifiers for this entity.
- CNNVD-201910-1685cnnvd
- EUVD-2019-0721enisa_euvd
- GHSA-2598-2f59-rmhqenisa_euvd
- SNYK-JS-SEQUELIZE-450222osv
sources
Which sources assert this record, and when.
references (7)
External citations — patches, advisories, analysis.
- https://github.com/sequelize/sequelize/commit/ee4017379db0059566ecb5424274ad4e2d66bc68cnnvd
- https://nvd.nist.gov/vuln/detail/CVE-2019-10749cnnvd
- https://snyk.io/vuln/SNYK-JS-SEQUELIZE-450222cnnvd
- https://github.com/sequelize/sequelize/commit/ee4017379db0059566ecb5424274ad4e2d66bc68enisa_euvd
- https://snyk.io/vuln/SNYK-JS-SEQUELIZE-450222enisa_euvd
- https://github.com/sequelize/sequelize/commit/ee4017379db0059566ecb5424274ad4e2d66bc68Patchnvd
- https://snyk.io/vuln/SNYK-JS-SEQUELIZE-450222ExploitThird Party Advisorynvd
Attackers weaponise vulnerabilities like this against internet-exposed services. See what is exposed on your perimeter with a free passive scan.
Free scan