GHSA-2598-2f59-rmhq

ghsaUSosv

SQL Injection in sequelize

view advisory published 2019-11-08Licence: CC-BY-4.0

Versions of `sequelize` prior to 3.35.1 are vulnerable to SQL Injection. The package fails to sanitize JSON path keys in the Postgres dialect, which may allow attackers to inject SQL statements and execute arbitrary SQL queries. ## Recommendation Upgrade to version 3.35.1 or later.

01

describes (1)

Related CVEs.

IDseverity exploitable
CVE-2019-10749UScritical9.8—
sequelize before version 3.35.1 allows attackers to perform a SQL Injection due to the JSON path keys not being properly sanitized in the Postgres dialect.
02

references

External citations — patches, advisories, analysis.

scry

Advisories like this name the exposed products attackers go after on your perimeter. See what is exposed on your perimeter with a free passive scan.

Free scan