CVE-2019-10742
mediumpriority · track · 42EPSS 0.061 · 93 %ileexploit · PoCEUUSEPSS · scored 2026-10-27
Axios up to and including 0.18.0 allows attackers to cause a denial of service (application crash) by continuing to accepting content after maxContentLength is exceeded.
cvss
Technical severity, 0–10. One row per scoring source.
base score 0–10 · higher = more severe · hover a vector to decode⚠ sources disagree · medium–high · 5–7.5
weaknesses
The CWE weakness classes this flaw belongs to.
exploits (1)
Public proof-of-concept and weaponised exploit code.
- Viniciuspxf/CVE-2019-10742Viniciuspxf/CVE-2019-10742PoC · poc_in_github
affected products (3)
Products and version ranges known to be affected.
advisories (1)
Vendor and ecosystem advisories describing this.
- GHSA-42xw-2xvc-qx8mDenial of Service in axios2019-05-29ghsa · osvUS
Versions of `axios` prior to 0.18.1 are vulnerable to Denial of Service. If a request exceeds the `maxContentLength` property, the package prints an error but does not stop the request. This may cause high CPU usage and lead to Denial of Service. ## Recommendation Upgrade to 0.18.1 or later.
also known as (3)
Other names and identifiers for this entity.
sources
Which sources assert this record, and when.
references (10)
External citations — patches, advisories, analysis.
- https://app.snyk.io/vuln/SNYK-JS-AXIOS-174505cnnvd
- https://github.com/axios/axios/issues/1098cnnvd
- https://github.com/axios/axios/pull/1485cnnvd
- https://nvd.nist.gov/vuln/detail/CVE-2019-10742cnnvd
- https://app.snyk.io/vuln/SNYK-JS-AXIOS-174505enisa_euvd
- https://github.com/axios/axios/issues/1098enisa_euvd
- https://github.com/axios/axios/pull/1485enisa_euvd
- https://app.snyk.io/vuln/SNYK-JS-AXIOS-174505ExploitPatchThird Party Advisorynvd
Attackers weaponise vulnerabilities like this against internet-exposed services. See what is exposed on your perimeter with a free passive scan.
Free scan