GHSA-42xw-2xvc-qx8m

ghsaUSosv

Denial of Service in axios

view advisory published 2019-05-29Licence: CC-BY-4.0

Versions of `axios` prior to 0.18.1 are vulnerable to Denial of Service. If a request exceeds the `maxContentLength` property, the package prints an error but does not stop the request. This may cause high CPU usage and lead to Denial of Service. ## Recommendation Upgrade to 0.18.1 or later.

01

describes (1)

Related CVEs.

IDseverity exploitable
CVE-2019-10742UShigh7.5Exploit
Axios up to and including 0.18.0 allows attackers to cause a denial of service (application crash) by continuing to accepting content after maxContentLength is exceeded.
02

references

External citations — patches, advisories, analysis.

scry

Advisories like this name the exposed products attackers go after on your perimeter. See what is exposed on your perimeter with a free passive scan.

Free scan