CVE-2019-10206
mediumpriority · track · 27EPSS 0.015 · 74 %ileDEEURUUSEPSS · scored 2026-10-27
ansible-playbook -k and ansible cli tools, all versions 2.8.x before 2.8.4, all 2.7.x before 2.7.13 and all 2.6.x before 2.6.19, prompt passwords by expanding them from templates as they could contain special characters. Passwords should be wrapped to prevent templates trigger and exposing them.
remediations
Vendor fix, mitigation, or workaround guidance, as published by each source.
A vendor fix is available.
- Fixedansible-0:2.6.19-1.el7ae.noarch as a component of Red Hat OpenStack Platform 14.0redhat_csaf
For details on how to apply this update, which includes the changes described in this advisory, refer to: https://access.redhat.com/articles/11258
https://access.redhat.com/errata/RHSA-2019:3744 - Fixedansible-0:2.6.19-1.el7ae.src as a component of Red Hat OpenStack Platform 14.0redhat_csaf
For details on how to apply this update, which includes the changes described in this advisory, refer to: https://access.redhat.com/articles/11258
https://access.redhat.com/errata/RHSA-2019:3744 - Fixedansible-0:2.6.19-1.el7ae.noarch as a component of Red Hat OpenStack Platform 13.0redhat_csaf
For details on how to apply this update, which includes the changes described in this advisory, refer to: https://access.redhat.com/articles/11258
https://access.redhat.com/errata/RHSA-2019:3789 - Fixedansible-0:2.6.19-1.el7ae.src as a component of Red Hat OpenStack Platform 13.0redhat_csaf
For details on how to apply this update, which includes the changes described in this advisory, refer to: https://access.redhat.com/articles/11258
https://access.redhat.com/errata/RHSA-2019:3789
cvss
Technical severity, 0–10. One row per scoring source.
base score 0–10 · higher = more severe · hover a vector to decode
weaknesses
The CWE weakness classes this flaw belongs to.
affected products (52)
Products and version ranges known to be affected.
advisories (5)
Vendor and ecosystem advisories describing this.
- RHSA-2019:3744Red Hat Security Advisory: ansible security update2019-11-06csaf · redhat_csafUS
An update for ansible is now available for Red Hat OpenStack Platform 14.0 (Rocky). Red Hat Product Security has rated this update as having a security impact of Moderate. A Common Vulnerability Scoring System (CVSS) base score, which gives a detailed severity rating, is available for each vulnerability from the CVE link(s) in the References section.
- RHSA-2019:3789Red Hat Security Advisory: ansible security update2019-11-07csaf · redhat_csafUS
An update for ansible is now available for Red Hat OpenStack Platform 13.0 (Queens). Red Hat Product Security has rated this update as having a security impact of Moderate. A Common Vulnerability Scoring System (CVSS) base score, which gives a detailed severity rating, is available for each vulnerability from the CVE link(s) in the References section.
- WID-SEC-W-2023-3227Ansible: Schwachstelle ermöglicht Offenlegung von InformationenDeutsch2019-07-24csaf · cert_bundDE
Ein entfernter, authentisierter Angreifer kann eine Schwachstelle in Ansible ausnutzen, um Informationen offenzulegen.
- GHSA-cqmr-rcpr-cxh3Ansible password prompts could expose passwords2022-05-24ghsa · osvUS
ansible-playbook -k and ansible cli tools, all versions 2.8.x before 2.8.4, all 2.7.x before 2.7.13 and all 2.6.x before 2.6.19, prompt passwords by expanding them from templates as they could contain special characters. Passwords should be wrapped to prevent templates trigger and exposing them.
- PYSEC-2019-1452019-11-22vendor · osvUS
ansible-playbook -k and ansible cli tools, all versions 2.8.x before 2.8.4, all 2.7.x before 2.7.13 and all 2.6.x before 2.6.19, prompt passwords by expanding them from templates as they could contain special characters. Passwords should be wrapped to prevent templates trigger and exposing them.
also known as (7)
Other names and identifiers for this entity.
sources
Which sources assert this record, and when.
references (34)
External citations — patches, advisories, analysis.
- http://lists.opensuse.org/opensuse-security-announce/2020-04/msg00021.htmlcnnvd
- http://lists.opensuse.org/opensuse-security-announce/2020-04/msg00026.htmlcnnvd
- http://www.ansible.com/homecnnvd
- https://access.redhat.com/errata/RHSA-2019:2542cnnvd
- https://access.redhat.com/errata/RHSA-2019:2543cnnvd
- https://access.redhat.com/errata/RHSA-2019:2544cnnvd
- https://access.redhat.com/errata/RHSA-2019:2545cnnvd
- https://access.redhat.com/errata/RHSA-2019:3789cnnvd
Attackers weaponise vulnerabilities like this against internet-exposed services. See what is exposed on your perimeter with a free passive scan.
Free scan