CVE-2018-25193
highpriority · track · 0OT risk · elevatedEPSS 0.003 · 27 %ileDEEUEPSS · scored 2026-10-22
Mongoose Web Server 6.9 contains a denial of service vulnerability that allows remote attackers to crash the service by establishing multiple socket connections. Attackers can repeatedly create connections to the default port and send malformed data to exhaust server resources and cause service unavailability.
remediations
Vendor fix, mitigation, or workaround guidance, as published by each source.
A vendor fix is available.
- FixedPASvisupilz_psirt
Please visit the Pilz website (https://www.pilz.com/en-INT/search) and install the new version 'PASvisu 1.16.0' on to your device.
- FixedPASvisu <=1.15.1 installed on Firmware PMI v70Xe <=03.01.00 installed on PMIv7xxepilz_psirt
Please visit the Pilz website (https://www.pilz.com/en-INT/search) and install the new firmware image 'Firmware PMI v70Xe (visu 1.16.0) 04.00.00' on to your device.
- FixedPASvisu <=1.15.1 installed on Firmware PMI v8 <=2.2.2 installed on PMIv8xxpilz_psirt
Please visit the Pilz website (https://www.pilz.com/en-INT/search) and download 'Firmware PMI v8 Assistant (visu 1.16.0) 2.3.0' in order to install the new verison of the firmware on to your device.
- MitigationPASvisupilz_psirt
Limit network access to PASvisu server by using a firewall, a host-based firewall or similar measures.
- MitigationPASvisu <=1.15.1 installed on Firmware PMI v70Xe <=03.01.00 installed on PMIv7xxepilz_psirt
Limit network access to PASvisu server by using a firewall, a host-based firewall or similar measures.
- MitigationPASvisu <=1.15.1 installed on Firmware PMI v8 <=2.2.2 installed on PMIv8xxpilz_psirt
Limit network access to PASvisu server by using a firewall, a host-based firewall or similar measures.
cvss
Technical severity, 0–10. One row per scoring source.
base score 0–10 · higher = more severe · hover a vector to decode⚠ sources disagree · medium–high · 6.6–8.7
ssvc
A stakeholder decision — act, attend, or track — from exploitation and impact.
weaknesses
The CWE weakness classes this flaw belongs to.
affected products (9)
Products and version ranges known to be affected.
advisories (1)
Vendor and ecosystem advisories describing this.
- PPSA-2026-002Pilz: Vulnerability affecting PASvisu Runtime2026-04-23csaf · pilz_psirtDE
The PASvisu Runtime is affected by a vulnerability in a third-party component which can be exploited by malicious web requests.
also known as (3)
Other names and identifiers for this entity.
sources
Which sources assert this record, and when.
references (7)
External citations — patches, advisories, analysis.
- https://mongoose.ws/binary/Patchcnnvd
- https://www.exploit-db.com/exploits/45819cnnvd
- https://www.vulncheck.com/advisories/mongoose-web-server-denial-of-service-via-socket-connectioncnnvd
- https://www.exploit-db.com/exploits/45819enisa_euvd
- https://www.vulncheck.com/advisories/mongoose-web-server-denial-of-service-via-socket-connectionenisa_euvd
- https://www.exploit-db.com/exploits/45819nvd
- https://www.vulncheck.com/advisories/mongoose-web-server-denial-of-service-via-socket-connectionnvd
Attackers weaponise vulnerabilities like this against internet-exposed services. See what is exposed on your perimeter with a free passive scan.
Free scan