PPSA-2026-002

csafDEpilz_psirt

Pilz: Vulnerability affecting PASvisu Runtime

view advisory published 2026-04-23

The PASvisu Runtime is affected by a vulnerability in a third-party component which can be exploited by malicious web requests.

01

describes (1)

Related CVEs.

IDseverity exploitable
CVE-2018-25193US—OT elevated—
Mongoose Web Server 6.9 contains a denial of service vulnerability that allows remote attackers to crash the service by establishing multiple socket connections. Attackers can repe…
02

references

External citations — patches, advisories, analysis.

03

remediations (6)

  • MitigationPASvisu

    Limit network access to PASvisu server by using a firewall, a host-based firewall or similar measures.

  • MitigationPASvisu <=1.15.1 installed on Firmware PMI v70Xe <=03.01.00 installed on PMIv7xxe

    Limit network access to PASvisu server by using a firewall, a host-based firewall or similar measures.

  • MitigationPASvisu <=1.15.1 installed on Firmware PMI v8 <=2.2.2 installed on PMIv8xx

    Limit network access to PASvisu server by using a firewall, a host-based firewall or similar measures.

  • FixedPASvisu

    Please visit the Pilz website (https://www.pilz.com/en-INT/search) and install the new version 'PASvisu 1.16.0' on to your device.

  • FixedPASvisu <=1.15.1 installed on Firmware PMI v70Xe <=03.01.00 installed on PMIv7xxe

    Please visit the Pilz website (https://www.pilz.com/en-INT/search) and install the new firmware image 'Firmware PMI v70Xe (visu 1.16.0) 04.00.00' on to your device.

  • FixedPASvisu <=1.15.1 installed on Firmware PMI v8 <=2.2.2 installed on PMIv8xx

    Please visit the Pilz website (https://www.pilz.com/en-INT/search) and download 'Firmware PMI v8 Assistant (visu 1.16.0) 2.3.0' in order to install the new verison of the firmware on to your device.

scry

Advisories like this name the exposed products attackers go after on your perimeter. See what is exposed on your perimeter with a free passive scan.

Free scan