CVE-2017-10906
highpriority · track · 41EPSS 0.046 · 92 %ileEUUSEPSS · scored 2026-10-27
Escape sequence injection vulnerability in Fluentd versions 0.12.29 through 0.12.40 may allow an attacker to change the terminal UI or execute arbitrary commands on the device via unspecified vectors.
remediations
Vendor fix, mitigation, or workaround guidance, as published by each source.
A vendor fix is available.
- Fixedfluentd-0:0.12.41-1.el7.noarch as a component of Red Hat OpenStack Platform 13.0 Operational Tools for RHEL 7redhat_csaf
For details on how to apply this update, which includes the changes described in this advisory, refer to: https://access.redhat.com/articles/11258
https://access.redhat.com/errata/RHSA-2018:2225 - Fixedfluentd-0:0.12.41-1.el7.src as a component of Red Hat OpenStack Platform 13.0 Operational Tools for RHEL 7redhat_csaf
For details on how to apply this update, which includes the changes described in this advisory, refer to: https://access.redhat.com/articles/11258
https://access.redhat.com/errata/RHSA-2018:2225
cvss
Technical severity, 0–10. One row per scoring source.
base score 0–10 · higher = more severe · hover a vector to decode⚠ sources disagree · medium–critical · 5.3–10
weaknesses
The CWE weakness classes this flaw belongs to.
affected products (17)
Products and version ranges known to be affected.
advisories (2)
Vendor and ecosystem advisories describing this.
- RHSA-2018:2225Red Hat Security Advisory: fluentd security update2018-07-19csaf · redhat_csafUS
An update for fluentd is now available for Red Hat OpenStack Platform 13.0 Operational Tools for Red Hat Enterprise Linux 7. Red Hat Product Security has rated this update as having a security impact of Moderate. A Common Vulnerability Scoring System (CVSS) base score, which gives a detailed severity rating, is available for each vulnerability from the CVE link(s) in the References section.
- GHSA-5jrp-w8fr-mrwwFluentd Escape Sequence Injection Vulnerability2022-05-13ghsa · osvUS
Escape sequence injection vulnerability in Fluentd versions 0.12.29 through 0.12.40 may allow an attacker to change the terminal UI or execute arbitrary commands on the device via unspecified vectors.
also known as (3)
Other names and identifiers for this entity.
sources
Which sources assert this record, and when.
references (12)
External citations — patches, advisories, analysis.
- https://access.redhat.com/errata/RHSA-2018:2225cnnvd
- https://github.com/fluent/fluentd/blob/v0.12/CHANGELOG.md#bug-fixescnnvd
- https://github.com/fluent/fluentd/pull/1733cnnvd
- https://jvn.jp/en/vu/JVNVU95124098/index.htmlcnnvd
- https://access.redhat.com/errata/RHSA-2018:2225enisa_euvd
- https://github.com/fluent/fluentd/blob/v0.12/CHANGELOG.md#bug-fixesenisa_euvd
- https://github.com/fluent/fluentd/pull/1733enisa_euvd
- https://jvn.jp/en/vu/JVNVU95124098/index.htmlenisa_euvd
Attackers weaponise vulnerabilities like this against internet-exposed services. See what is exposed on your perimeter with a free passive scan.
Free scan