CVE-2016-7103

mediumpriority · track · 34EPSS 0.292 · 98 %ileDEEURUUS
grimoire priorityP1 · Urgent
Exploitable?
—
no known exploitation
Likely / severe?
29.2% (98th) EPSS
CVSS 4.3 · medium
Is it mine?
53 products
Check your exposure
Who says so?
7 sources
cnnvd · enisa_euvd · fstec_bdu · cisa_csaf_ot

EPSS · scored 2026-10-27

Cross-site scripting (XSS) vulnerability in jQuery UI before 1.12.0 might allow remote attackers to inject arbitrary web script or HTML via the closeText parameter of the dialog function.

01

remediations

Vendor fix, mitigation, or workaround guidance, as published by each source.

A vendor fix is available.

  • Fixedpython-XStatic-jquery-ui-0:1.12.0.1-1.el7ost.noarch as a component of Red Hat Enterprise Linux OpenStack Platform 7.0 (Kilo) for RHEL 7redhat_csaf

    For details on how to apply this update, which includes the changes described in this advisory, refer to: https://access.redhat.com/articles/11258

    https://access.redhat.com/errata/RHSA-2017:0161
  • Fixedpython-XStatic-jquery-ui-0:1.12.0.1-1.el7ost.src as a component of Red Hat Enterprise Linux OpenStack Platform 7.0 (Kilo) for RHEL 7redhat_csaf

    For details on how to apply this update, which includes the changes described in this advisory, refer to: https://access.redhat.com/articles/11258

    https://access.redhat.com/errata/RHSA-2017:0161
  • Fixedphoenix_contact_psirt

    Update to Firmware Release 2019.0 LTS or later. Update to PLCnext Engineer Release 2019.0 LTS or later. Update A, 30.08.2019 With Firmware Release 2019.6 an option was added to the web-based management that allows the user to permanently disable storage of configuration data to the SD-Card. The device can now be operated without SD-Card and ignores any inserted SD-Card. We recommend using this new configuration option for application scenarios where physical access to the device cannot be restricted effectively.

  • FixedAXC F 2152cisa_csaf_ot

    Follow the advice concerning SD card usage in the manual “Art.-Nr. 107708: UM EN AXC F 2152 Installing, starting up, and operating the AXC F 2152 controller um_en_axc_f_2152_107708_en_02.pdf” that can be found on the product page below:

    https://www.phoenixcontact.com/online/portal/us/?uri=pxc-oc-itemdetail:pid=2404267&library=usen&pcck=P-21-14-01&tab=1&selectedCategory=ALL
  • MitigationAXC F 2152cisa_csaf_ot

    Disable Basic128Rsa15 security policy in OPC Servers configuration. Use only Basic256 or higher.

02

cvss

Technical severity, 0–10. One row per scoring source.

6.1
010

base score 0–10 · higher = more severe · hover a vector to decode

v2.04.3mediumAV:N/AC:M/Au:N/C:N/I:P/A:Nprimary · NVD / NIST USexploitability 8.6 · impact 2.9
v3.16.1mediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:Nprimary · NVD / NIST USexploitability 2.8 · impact 2.7
v2.04.3mediumAV:N/AC:M/Au:N/C:N/I:P/A:Nsecondary · Red Hat Product Security US
v3.06.1mediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:Nsecondary · Red Hat Product Security US
v3.06.1mediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:Nsecondary · CISA US
v3.16.1mediumAV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:Nsecondary · FSTEC (BDU) RU
v3.16.1mediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:Nsecondary · OSV
v3.16.1mediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:Nsecondary · Phoenix Contact PSIRT DE
v3.15.6mediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N/E:Usecondary · CVSS-BT (t0sche)
03

weaknesses

The CWE weakness classes this flaw belongs to.

04

affected products (53)

Products and version ranges known to be affected.

05

advisories (4)

Vendor and ecosystem advisories describing this.

  • RHSA-2017:0161Red Hat Security Advisory: python-XStatic-jquery-ui security update2017-01-19csaf · redhat_csafUS

    An update for python-XStatic-jquery-ui is now available for Red Hat Enterprise Linux OpenStack Platform 7.0 (Kilo) for RHEL 7. Red Hat Product Security has rated this update as having a security impact of Low. A Common Vulnerability Scoring System (CVSS) base score, which gives a detailed severity rating, is available for each vulnerability from the CVE link(s) in the References section.

  • VDE-2019-009PHOENIX CONTACT: Multiple Vulnerabilities in AXC F 21522019-06-04csaf · phoenix_contact_psirtDE

    Multiple vulnerabilities have been identified in PHOENIX CONTACT AXC F 2152 with firmware versions 1.x

  • GHSA-hpcf-8vf9-q4gjjQuery-UI vulnerable to Cross-site Scripting in dialog closeText2017-10-24ghsa · osvUS

    Affected versions of `jquery-ui` are vulnerable to a cross-site scripting vulnerability when arbitrary user input is supplied as the value of the `closeText` parameter in the `dialog` function. jQuery-UI is a library for manipulating UI elements via jQuery. Version 1.11.4 has a cross site scripting (XSS) vulnerability in the `closeText` parameter of the `dialog` function. If your application passes user input to this parameter, it may be vulnerable to XSS via this attack vector. ## Recommendation Upgrade to jQuery-UI 1.12.0 or later.

  • ICSA-19-155-01PHOENIX CONTACT PLCNext AXC F 21522019-06-04icsa · cisa_csaf_otUS

    Successful exploitation of these vulnerabilities could allow an attacker to decrypt passwords, bypass authentication, and deny service to the device. In addition, these vulnerabilities could interact with third-party vulnerabilities to cause other impacts to integrity, confidentiality, and availability.

06

also known as (5)

Other names and identifiers for this entity.

07

sources

Which sources assert this record, and when.

09

references (103)

External citations — patches, advisories, analysis.

scry

Attackers weaponise vulnerabilities like this against internet-exposed services. See what is exposed on your perimeter with a free passive scan.

Free scan