CVE-2025-21613
criticalPriorität · verfolgen · 0EPSS 0.013 · 70. PerzentilDEEURUUSEPSS · bewertet 2026-10-27
go-git is a highly extensible git implementation library written in pure Go. An argument injection vulnerability was discovered in go-git versions prior to v5.13. Successful exploitation of this vulnerability could allow an attacker to set arbitrary values to git-upload-pack flags. This only happens when the file transport protocol is being used, as that is the only protocol that shells out to git binaries. This vulnerability is fixed in 5.13.0.
Behebungen
Hersteller-Fix, Mitigation oder Workaround, wie von den Quellen veröffentlicht.
Ein Hersteller-Fix ist verfügbar.
- Behobengovulncheck-vulndb-0.0.20250108T191942-150000.1.26.1.noarch as component of SUSE Linux Enterprise Module for Package Hub 15 SP6suse_csaf
To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
- Behobengovulncheck-vulndb-0.0.20250108T191942-150000.1.26.1.noarch as component of openSUSE Leap 15.6suse_csaf
To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
- Behobentrivy-0.66.0-bp160.1.1.aarch64 as component of openSUSE Leap 16.0suse_csaf
To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
- Behobentrivy-0.66.0-bp160.1.1.ppc64le as component of openSUSE Leap 16.0suse_csaf
To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
- Behobentrivy-0.66.0-bp160.1.1.s390x as component of openSUSE Leap 16.0suse_csaf
To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
- Behobentrivy-0.66.0-bp160.1.1.x86_64 as component of openSUSE Leap 16.0suse_csaf
To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
- Behobentrivy-0:0.68.2-160000.1.1.aarch64 as component of openSUSE Leap 16.0suse_csaf
To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
- Behobentrivy-0:0.68.2-160000.1.1.ppc64le as component of openSUSE Leap 16.0suse_csaf
To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
- Behobentrivy-0:0.68.2-160000.1.1.s390x as component of openSUSE Leap 16.0suse_csaf
To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
- Behobentrivy-0:0.68.2-160000.1.1.x86_64 as component of openSUSE Leap 16.0suse_csaf
To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
cvss
Technischer Schweregrad, 0–10. Eine Zeile je Quelle.
Basiswert 0–10 · höher = schwerwiegender · Vektor überfahren zum Auflösen⚠ Quellen uneinig · high–critical · 7.2–9.8
SSVC
Eine Handlungsentscheidung — aus Ausnutzung und Auswirkung.
schwächen
Die CWE-Schwächeklassen, zu denen dies gehört.
betroffene Produkte (38)
Betroffene Produkte und Versionsbereiche.
- Red Hat Enterprise Linux Advanced Cluster Security for Kubernetes 4alle Versionencert_bundDEcpe:/o:redhat:enterprise_linux:advanced_cluster_security_for_kubernetes_4
Advisories (6)
Hersteller- und Ökosystem-Meldungen dazu.
- SUSE-SU-2025:0060-1Security update for govulncheck-vulndb2025-01-10csaf · suse_csafDE
Security update for govulncheck-vulndb
- WID-SEC-W-2025-0123Red Hat Enterprise Linux und and OpenShift (go-git): Mehrere SchwachstellenDeutsch2025-01-19csaf · cert_bundDE
Ein entfernter anonymer Angreifer kann mehrere Schwachstellen in Red Hat Enterprise Linux in der Grafana Komponente ausnutzen, um beliebigen Code auszuführen, vertrauliche Informationen preiszugeben und einen Denial-of-Service-Zustand zu erzeugen.
- openSUSE-SU-2025:20117-1Security update for trivy2025-11-27csaf · suse_csafDE
Security update for trivy
- openSUSE-SU-2026:20798-1Security update for trivy2026-02-13csaf · suse_csafDE
Security update for trivy
- GHSA-v725-9546-7q7mgo-git has an Argument Injection via the URL field2025-01-06ghsa · osvUS
### Impact An argument injection vulnerability was discovered in `go-git` versions prior to `v5.13`. Successful exploitation of this vulnerability could allow an attacker to set arbitrary values to [git-upload-pack flags](https://git-scm.com/docs/git-upload-pack). This only happens when the `file` transport protocol is being used, as that is the only protocol that shells out to `git` binaries. ### Affected versions Users running versions of `go-git` from `v4` and above are recommended to upgrade to `v5.13` in order to mitigate this vulnerability. ### Workarounds In cases where a bump to the latest version of `go-git` is not possible, we recommend users to enforce restrict validation rules for values passed in the URL field. ## Credit Thanks to @vin01 for responsibly disclosing this vulnerability to us.
- GO-2025-3368Argument Injection via the URL field in github.com/go-git/go-git2025-01-07vendor · osvUS
Argument Injection via the URL field in github.com/go-git/go-git
auch bekannt als (6)
Weitere Namen und Kennungen dieser Entität.
quellen
Welche Quellen diesen Datensatz belegen und wann.
Referenzen (5)
Externe Belege — Patches, Meldungen, Analysen.
- https://access.redhat.com/security/cve/cve-2025-21613cnnvd
- https://github.com/go-git/go-git/security/advisories/GHSA-v725-9546-7q7mcnnvd
- https://vigilance.fr/vulnerability/go-git-privilege-escalation-via-Git-upload-pack-Flags-46131cnnvd
- https://github.com/go-git/go-git/security/advisories/GHSA-v725-9546-7q7menisa_euvd
- https://github.com/go-git/go-git/security/advisories/GHSA-v725-9546-7q7mVendor Advisorynvd
Angreifer nutzen Schwachstellen wie diese gegen im Internet exponierte Dienste aus. Sehen Sie mit einem kostenlosen Passiv-Scan, was exponiert ist.
Kostenloser Scan