CVE-2024-26146
highPriorität · verfolgen · 31EPSS 0.020 · 81. PerzentilDEEURUUSEPSS · bewertet 2026-10-27
Rack is a modular Ruby web server interface. Carefully crafted headers can cause header parsing in Rack to take longer than expected resulting in a possible denial of service issue. Accept and Forwarded headers are impacted. Ruby 3.2 has mitigations for this problem, so Rack applications using Ruby 3.2 or newer are unaffected. This vulnerability is fixed in 2.0.9.4, 2.1.4.4, 2.2.8.1, and 3.0.9.1.
Behebungen
Hersteller-Fix, Mitigation oder Workaround, wie von den Quellen veröffentlicht.
Ein Hersteller-Fix ist verfügbar.
- Behobenruby4.0-rubygem-rack-2.2-0:2.2.22-1.1.aarch64 as component of openSUSE Tumbleweedsuse_csaf
To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
- Behobenruby4.0-rubygem-rack-2.2-0:2.2.22-1.1.ppc64le as component of openSUSE Tumbleweedsuse_csaf
To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
- Behobenruby4.0-rubygem-rack-2.2-0:2.2.22-1.1.s390x as component of openSUSE Tumbleweedsuse_csaf
To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
- Behobenruby4.0-rubygem-rack-2.2-0:2.2.22-1.1.x86_64 as component of openSUSE Tumbleweedsuse_csaf
To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
- Behobenruby4.0-rubygem-rack-0:3.1.18-1.3.aarch64 as component of openSUSE Tumbleweedsuse_csaf
To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
- Behobenruby4.0-rubygem-rack-0:3.1.18-1.3.ppc64le as component of openSUSE Tumbleweedsuse_csaf
To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
- Behobenruby4.0-rubygem-rack-0:3.1.18-1.3.s390x as component of openSUSE Tumbleweedsuse_csaf
To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
- Behobenruby4.0-rubygem-rack-0:3.1.18-1.3.x86_64 as component of openSUSE Tumbleweedsuse_csaf
To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
cvss
Technischer Schweregrad, 0–10. Eine Zeile je Quelle.
Basiswert 0–10 · höher = schwerwiegender · Vektor überfahren zum Auflösen⚠ Quellen uneinig · medium–high · 5.3–7.5
SSVC
Eine Handlungsentscheidung — aus Ausnutzung und Auswirkung.
schwächen
Die CWE-Schwächeklassen, zu denen dies gehört.
betroffene Produkte (28)
Betroffene Produkte und Versionsbereiche.
Advisories (4)
Hersteller- und Ökosystem-Meldungen dazu.
- WID-SEC-W-2024-0911Red Hat Enterprise Linux (pcs): Mehrere Schwachstellen ermöglichen Denial of ServiceDeutsch2024-04-16csaf · cert_bundDE
Ein entfernter, anonymer Angreifer kann mehrere Schwachstellen in Red Hat Enterprise Linux (pcs) ausnutzen, um einen Denial of Service Angriff durchzuführen.
- openSUSE-SU-2026:10286-1ruby4.0-rubygem-rack-2.2-2.2.22-1.1 on GA media2026-03-04csaf · suse_csafDE
ruby4.0-rubygem-rack-2.2-2.2.22-1.1 on GA media
- openSUSE-SU-2026:10358-1ruby4.0-rubygem-rack-3.1.18-1.3 on GA media2026-03-13csaf · suse_csafDE
ruby4.0-rubygem-rack-3.1.18-1.3 on GA media
- GHSA-54rr-7fvw-6x8fRack Header Parsing leads to Possible Denial of Service Vulnerability2024-02-28ghsa · osvUS
# Possible Denial of Service Vulnerability in Rack Header Parsing There is a possible denial of service vulnerability in the header parsing routines in Rack. This vulnerability has been assigned the CVE identifier CVE-2024-26146. Versions Affected: All. Not affected: None Fixed Versions: 2.0.9.4, 2.1.4.4, 2.2.8.1, 3.0.9.1 Impact ------ Carefully crafted headers can cause header parsing in Rack to take longer than expected resulting in a possible denial of service issue. Accept and Forwarded headers are impacted. Ruby 3.2 has mitigations for this problem, so Rack applications using Ruby 3.2 or newer are unaffected. Releases -------- The fixed releases are available at the normal locations. Workarounds ----------- There are no feasible workarounds for this issue. Patches ------- To aid users who aren't able to upgrade immediately we have provided patches for the two supported release series. They are in git-am format and consist of a single changeset. * 2-0-header-redos.patch - Patch for 2.0 series * 2-1-header-redos.patch - Patch for 2.1 series * 2-2-header-redos.patch - Patch for 2.2 series * 3-0-header-redos.patch - Patch for 3.0 series Credits ------- Thanks to [svalkanov](https://hackerone.com/svalkanov) for reporting this and providing patches!
auch bekannt als (4)
Weitere Namen und Kennungen dieser Entität.
quellen
Welche Quellen diesen Datensatz belegen und wann.
Referenzen (29)
Externe Belege — Patches, Meldungen, Analysen.
- https://cxsecurity.com/cveshow/CVE-2024-26146/cnnvd
- https://discuss.rubyonrails.org/t/possible-denial-of-service-vulnerability-in-rack-header-parsing/84942cnnvd
- https://github.com/rack/rack/commit/30b8e39a578b25d4bdcc082c1c52c6f164b59716cnnvd
- https://github.com/rack/rack/commit/6c5d90bdcec0949f7ba06db62fb740dab394b582cnnvd
- https://github.com/rack/rack/commit/a227cd793778c7c3a827d32808058571569cda6fcnnvd
- https://github.com/rack/rack/commit/e4c117749ba24a66f8ec5a08eddf68deeb425ccdcnnvd
- https://github.com/rack/rack/security/advisories/GHSA-54rr-7fvw-6x8fcnnvd
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/rack/CVE-2024-26146.ymlcnnvd
Angreifer nutzen Schwachstellen wie diese gegen im Internet exponierte Dienste aus. Sehen Sie mit einem kostenlosen Passiv-Scan, was exponiert ist.
Kostenloser Scan