CVE-2022-39341
criticalPriorität · verfolgen · 39OT-Risiko · erhöhtEPSS 0.011 · 67. PerzentilEUUSEPSS · bewertet 2026-10-27
OpenFGA is an authorization/permission engine. Versions prior to version 0.2.4 are vulnerable to authorization bypass under certain conditions. Users who have wildcard (`*`) defined on tupleset relations in their authorization model are vulnerable. Version 0.2.4 contains a patch for this issue.
cvss
Technischer Schweregrad, 0–10. Eine Zeile je Quelle.
Basiswert 0–10 · höher = schwerwiegender · Vektor überfahren zum Auflösen⚠ Quellen uneinig · medium–critical · 5.9–9.8
schwächen
Die CWE-Schwächeklassen, zu denen dies gehört.
betroffene Produkte (3)
Betroffene Produkte und Versionsbereiche.
Advisories (2)
Hersteller- und Ökosystem-Meldungen dazu.
- GHSA-vj4m-83m8-xpw5OpenFGA Authorization Bypass via tupleset wildcard2022-10-25ghsa · osvUS
### Overview During our internal security assessment, it was discovered that OpenFGA versions `v0.2.3` and prior are vulnerable to authorization bypass under certain conditions. ### Am I affected? You are affected by this vulnerability if you are using `openfga/openfga` version `v0.2.3` and you added a tuple with a wildcard (*) assigned to a tupleset relation (the right hand side of a ‘from’ statement). ### How to fix that? Upgrade to version `v0.2.4`. ### Backward Compatibility This update is not backward compatible with any authorization model that uses wildcard on a tupleset relation.
- GO-2022-1080OpenFGA Authorization Bypass via tupleset wildcard in github.com/openfga/openfga2024-08-21vendor · osvUS
OpenFGA Authorization Bypass via tupleset wildcard in github.com/openfga/openfga
auch bekannt als (5)
Weitere Namen und Kennungen dieser Entität.
quellen
Welche Quellen diesen Datensatz belegen und wann.
Referenzen (11)
Externe Belege — Patches, Meldungen, Analysen.
- https://cxsecurity.com/cveshow/CVE-2022-39341/cnnvd
- https://github.com/openfga/openfga/commit/b466769cc100b2065047786578718d313f52695bcnnvd
- https://github.com/openfga/openfga/releases/tag/v0.2.4cnnvd
- https://github.com/openfga/openfga/security/advisories/GHSA-vj4m-83m8-xpw5cnnvd
- https://nvd.nist.gov/vuln/detail/CVE-2022-39341cnnvd
- https://github.com/openfga/openfga/commit/b466769cc100b2065047786578718d313f52695benisa_euvd
- https://github.com/openfga/openfga/releases/tag/v0.2.4enisa_euvd
- https://github.com/openfga/openfga/security/advisories/GHSA-vj4m-83m8-xpw5enisa_euvd
Angreifer nutzen Schwachstellen wie diese gegen im Internet exponierte Dienste aus. Sehen Sie mit einem kostenlosen Passiv-Scan, was exponiert ist.
Kostenloser Scan