OpenFGA Authorization Bypass via tupleset wildcard
### Overview During our internal security assessment, it was discovered that OpenFGA versions `v0.2.3` and prior are vulnerable to authorization bypass under certain conditions. ### Am I affected? You are affected by this vulnerability if you are using `openfga/openfga` version `v0.2.3` and you added a tuple with a wildcard (*) assigned to a tupleset relation (the right hand side of a ‘from’ statement). ### How to fix that? Upgrade to version `v0.2.4`. ### Backward Compatibility This update is not backward compatible with any authorization model that uses wildcard on a tupleset relation.
beschreibt (1)
Zugehörige CVEs.
| ID | Schweregrad | ausnutzbar | ||
|---|---|---|---|---|
| CVE-2022-39341US | critical9.8OT erhöht | — | ||
OpenFGA is an authorization/permission engine. Versions prior to version 0.2.4 are vulnerable to authorization bypass under certain conditions. Users who have wildcard (`*`) define… | ||||
Referenzen
Externe Belege — Patches, Meldungen, Analysen.
- https://github.com/openfga/openfgaPACKAGE
- https://github.com/openfga/openfga/commit/b466769cc100b2065047786578718d313f52695bWEB
- https://github.com/openfga/openfga/releases/tag/v0.2.4WEB
- https://github.com/openfga/openfga/security/advisories/GHSA-vj4m-83m8-xpw5WEB
- https://nvd.nist.gov/vuln/detail/CVE-2022-39341ADVISORY
Advisories wie diese benennen die exponierten Produkte, die Angreifer auf Ihrer Angriffsfläche ins Visier nehmen. Sehen Sie mit einem kostenlosen Passiv-Scan, was exponiert ist.
Kostenloser Scan