CVE-2022-29181

mediumPriorität · verfolgen · 34EPSS 0.032 · 88. PerzentilDEEURUUS
grimoire priorityP3 · Track
Exploitable?
—
no known exploitation
Likely / severe?
3.23% (88th) EPSS
CVSS 6.4 · medium
Is it mine?
45 products
Prüfe deine Angriffsfläche
Who says so?
6 sources
cnnvd · enisa_euvd · fstec_bdu · cert_bund

EPSS · bewertet 2026-10-27

Nokogiri is an open source XML and HTML library for Ruby. Nokogiri prior to version 1.13.6 does not type-check all inputs into the XML and HTML4 SAX parsers, allowing specially crafted untrusted inputs to cause illegal memory access errors (segfault) or reads from unrelated memory. Version 1.13.6 contains a patch for this issue. As a workaround, ensure the untrusted input is a `String` by calling `#to_s` or equivalent.

01

Behebungen

Hersteller-Fix, Mitigation oder Workaround, wie von den Quellen veröffentlicht.

Ein Hersteller-Fix ist verfügbar.

  • Behobenruby4.0-rubygem-nokogiri-0:1.18.9-1.4.aarch64 as component of openSUSE Tumbleweedsuse_csaf

    To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".

  • Behobenruby4.0-rubygem-nokogiri-0:1.18.9-1.4.ppc64le as component of openSUSE Tumbleweedsuse_csaf

    To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".

  • Behobenruby4.0-rubygem-nokogiri-0:1.18.9-1.4.s390x as component of openSUSE Tumbleweedsuse_csaf

    To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".

  • Behobenruby4.0-rubygem-nokogiri-0:1.18.9-1.4.x86_64 as component of openSUSE Tumbleweedsuse_csaf

    To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".

02

cvss

Technischer Schweregrad, 0–10. Eine Zeile je Quelle.

8.2
010

Basiswert 0–10 · höher = schwerwiegender · Vektor überfahren zum Auflösen⚠ Quellen uneinig · medium–high · 6.4–8.2

v2.06.4mediumAV:N/AC:L/Au:N/C:P/I:N/A:Pprimary · NVD / NIST USAusnutzbarkeit 10 · Auswirkung 4.9
v3.18.2highCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:Hprimary · NVD / NIST USAusnutzbarkeit 3.9 · Auswirkung 4.2
v3.18.2highAV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:Hsecondary · FSTEC (BDU) RU
v3.18.2highCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:Hsecondary · ENISA EU
v3.18.2highCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:Hsecondary · security-advisories@github.comAusnutzbarkeit 3.9 · Auswirkung 4.2
v3.18.2highCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:Hsecondary · OSV
v3.17.5highCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:H/E:Usecondary · CVSS-BT (t0sche)
v3.17.1highCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:Hsecondary · SUSE Product Security
03

SSVC

Eine Handlungsentscheidung — aus Ausnutzung und Auswirkung.

Exploitation: poc · Automatable: yes · Technical Impact: partialcoordinatorcisa_ssvcUS
04

schwächen

Die CWE-Schwächeklassen, zu denen dies gehört.

05

betroffene Produkte (45)

Betroffene Produkte und Versionsbereiche.

06

Advisories (4)

Hersteller- und Ökosystem-Meldungen dazu.

  • WID-SEC-W-2022-1935Microsoft GitHub Enterprise: Mehrere SchwachstellenDeutsch2022-11-01csaf · cert_bundDE

    Ein entfernter, anonymer Angreifer kann mehrere Schwachstellen in Microsoft GitHub Enterprise ausnutzen, um Informationen offenzulegen oder einen Denial of Service Zustand herbeizuführen.

  • WID-SEC-W-2022-2313Apple macOS: Mehrere SchwachstellenDeutsch2022-12-13csaf · cert_bundDE

    Ein entfernter Angreifer kann mehrere Schwachstellen in Apple macOS ausnutzen, um den Benutzer zu täuschen, Informationen offenzulegen, Sicherheitsmechanismen zu umgehen, Rechte zu erweitern und beliebigen Code mit Kernel-Rechten auszuführen.

  • openSUSE-SU-2026:10356-1ruby4.0-rubygem-nokogiri-1.18.9-1.4 on GA media2026-03-13csaf · suse_csafDE

    ruby4.0-rubygem-nokogiri-1.18.9-1.4 on GA media

  • GHSA-xh29-r2w5-wx8mNokogiri Improperly Handles Unexpected Data Type2022-05-23ghsa · osvUS

    ### Summary Nokogiri `< v1.13.6` does not type-check all inputs into the XML and HTML4 SAX parsers. For CRuby users, this may allow specially crafted untrusted inputs to cause illegal memory access errors (segfault) or reads from unrelated memory. ### Severity The Nokogiri maintainers have evaluated this as **High 8.2** (CVSS3.1). ### Mitigation CRuby users should upgrade to Nokogiri `>= 1.13.6`. JRuby users are not affected. ### Workarounds To avoid this vulnerability in affected applications, ensure the untrusted input is a `String` by calling `#to_s` or equivalent. ### Credit This vulnerability was responsibly reported by @agustingianni and the Github Security Lab.

07

auch bekannt als (4)

Weitere Namen und Kennungen dieser Entität.

08

quellen

Welche Quellen diesen Datensatz belegen und wann.

veröffentlicht 2022-05-20geändert 2026-08-04
10

Referenzen (28)

Externe Belege — Patches, Meldungen, Analysen.

scry

Angreifer nutzen Schwachstellen wie diese gegen im Internet exponierte Dienste aus. Sehen Sie mit einem kostenlosen Passiv-Scan, was exponiert ist.

Kostenloser Scan