PPSA-2025-004

csafDEpilz_psirt

Pilz: Vulnerability affecting PASvisu Runtime

view advisory published 2025-10-20

The PASvisu Runtime is affected by a vulnerability in a third-party component which can be exploited by a malicious web request.

01

describes (1)

Related CVEs.

IDseverity exploitable
CVE-2025-51495US—Exploit
An integer overflow vulnerability exists in the WebSocket component of Mongoose 7.5 thru 7.17. By sending a specially crafted WebSocket request, an attacker can cause the applicati…
02

references

External citations — patches, advisories, analysis.

03

remediations (6)

  • MitigationPASvisu

    Limit network access to PASvisu server by using a firewall, a host-based firewall or similar measures.

  • MitigationPASvisu <=1.15.0 installed on Firmware PMI v70Xe <=03.00.00 installed on PMIv7xxe

    Limit network access to PASvisu server by using a firewall, a host-based firewall or similar measures.

  • MitigationPASvisu <=1.15.0 installed on Firmware PMI v8 <=2.2.1 installed on PMIv8xx

    Limit network access to PASvisu server by using a firewall, a host-based firewall or similar measures.

  • FixedPASvisu

    Please visit the Pilz website (https://www.pilz.com/en-INT/search) and install the new version 'PASvisu 1.15.1' on to your device.

  • FixedPASvisu <=1.15.0 installed on Firmware PMI v70Xe <=03.00.00 installed on PMIv7xxe

    Please visit the Pilz website (https://www.pilz.com/en-INT/search) and install the new firmware image 'Firmware PMI v70Xe (visu 1.15.1) 03.01.00' on to your device.

  • FixedPASvisu <=1.15.0 installed on Firmware PMI v8 <=2.2.1 installed on PMIv8xx

    Please visit the Pilz website (https://www.pilz.com/en-INT/search) and download 'Firmware PMI v8 Assistant (visu 1.15.1) 2.2.2' in order to install the new verison of the firmware on to your device.

scry

Advisories like this name the exposed products attackers go after on your perimeter. See what is exposed on your perimeter with a free passive scan.

Free scan