CVE-2025-51495
highpriority · track · 10EPSS 0.004 · 36 %ileexploit · PoCDEEUUSEPSS · scored 2026-10-27
An integer overflow vulnerability exists in the WebSocket component of Mongoose 7.5 thru 7.17. By sending a specially crafted WebSocket request, an attacker can cause the application to crash. If downstream vendors integrate this component improperly, the issue may lead to a buffer overflow.
remediations
Vendor fix, mitigation, or workaround guidance, as published by each source.
A vendor fix is available.
- FixedPASvisupilz_psirt
Please visit the Pilz website (https://www.pilz.com/en-INT/search) and install the new version 'PASvisu 1.15.1' on to your device.
- FixedPASvisu <=1.15.0 installed on Firmware PMI v70Xe <=03.00.00 installed on PMIv7xxepilz_psirt
Please visit the Pilz website (https://www.pilz.com/en-INT/search) and install the new firmware image 'Firmware PMI v70Xe (visu 1.15.1) 03.01.00' on to your device.
- FixedPASvisu <=1.15.0 installed on Firmware PMI v8 <=2.2.1 installed on PMIv8xxpilz_psirt
Please visit the Pilz website (https://www.pilz.com/en-INT/search) and download 'Firmware PMI v8 Assistant (visu 1.15.1) 2.2.2' in order to install the new verison of the firmware on to your device.
- MitigationPASvisupilz_psirt
Limit network access to PASvisu server by using a firewall, a host-based firewall or similar measures.
- MitigationPASvisu <=1.15.0 installed on Firmware PMI v70Xe <=03.00.00 installed on PMIv7xxepilz_psirt
Limit network access to PASvisu server by using a firewall, a host-based firewall or similar measures.
- MitigationPASvisu <=1.15.0 installed on Firmware PMI v8 <=2.2.1 installed on PMIv8xxpilz_psirt
Limit network access to PASvisu server by using a firewall, a host-based firewall or similar measures.
cvss
Technical severity, 0–10. One row per scoring source.
base score 0–10 · higher = more severe · hover a vector to decode
ssvc
A stakeholder decision — act, attend, or track — from exploitation and impact.
weaknesses
The CWE weakness classes this flaw belongs to.
exploits (1)
Public proof-of-concept and weaponised exploit code.
- cainiao159357/CVE-2025-51495cainiao159357/CVE-2025-51495PoC · poc_in_github
affected products (10)
Products and version ranges known to be affected.
advisories (1)
Vendor and ecosystem advisories describing this.
- PPSA-2025-004Pilz: Vulnerability affecting PASvisu Runtime2025-10-20csaf · pilz_psirtDE
The PASvisu Runtime is affected by a vulnerability in a third-party component which can be exploited by a malicious web request.
also known as (3)
Other names and identifiers for this entity.
sources
Which sources assert this record, and when.
references (11)
External citations — patches, advisories, analysis.
- http://mongoose.comcnnvd
- https://github.com/cainiao159357/CVE-2025-51495cnnvd
- https://github.com/cesanta/mongoosecnnvd
- https://github.com/cesanta/mongoose/pull/3131cnnvd
- https://github.com/cesanta/mongoose/releasesPatchcnnvd
- https://github.com/cainiao159357/CVE-2025-51495enisa_euvd
- https://github.com/cesanta/mongooseenisa_euvd
- https://github.com/cesanta/mongoose/pull/3131enisa_euvd
Attackers weaponise vulnerabilities like this against internet-exposed services. See what is exposed on your perimeter with a free passive scan.
Free scan