DeutschShown in its original language — a full translation is planned for a future version.
Red Hat OpenShift Service Mesh Containers: Mehrere Schwachstellen
view advisory published 2024-06-06
Ein Angreifer kann mehrere Schwachstellen in Red Hat OpenShift Service Mesh Containers ausnutzen, um Dateien zu manipulieren, einen 'Denial of Service'-Zustand erzuegen, beliebigen Code auszuführen, vertrauliche Informationen offenzulegen oder weitere nicht spezifizierte Angriffe durchzuführen.
01
describes (60)
Related CVEs.
| ID | severity | exploitable | ||
|---|---|---|---|---|
| CVE-2024-33602US | — | — | ||
nscd: netgroup cache assumes NSS callback uses in-buffer strings
The Name Service Cache Daemon's (nscd) netgroup cache can corrupt memory
when the NSS callback does not store all… | ||||
| CVE-2024-33601US | — | — | ||
nscd: netgroup cache may terminate daemon on memory allocation failure
The Name Service Cache Daemon's (nscd) netgroup cache uses xmalloc or
xrealloc and these functions may termi… | ||||
| CVE-2024-33600US | — | — | ||
nscd: Null pointer crashes after notfound response
If the Name Service Cache Daemon's (nscd) cache fails to add a not-found
netgroup response to the cache, the client request can… | ||||
| CVE-2024-33599US | — | — | ||
nscd: Stack-based buffer overflow in netgroup cache
If the Name Service Cache Daemon's (nscd) fixed size cache is exhausted
by client requests then a subsequent client request for… | ||||
| CVE-2023-6237US | — | — | ||
Issue summary: Checking excessively long invalid RSA public keys may take
a long time.
Impact summary: Applications that use the function EVP_PKEY_public_check()
to check RSA publ… | ||||
| CVE-2024-2961US | — | Exploit | ||
The iconv() function in the GNU C Library versions 2.39 and older may overflow the output buffer passed to it by up to 4 bytes when converting strings to the ISO-2022-CN-EXT charac… | ||||
| CVE-2023-45288US | — | Exploit | ||
An attacker may cause an HTTP/2 endpoint to read arbitrary amounts of header data by sending an excessive number of CONTINUATION frames. Maintaining HPACK state requires parsing an… | ||||
| CVE-2024-1313US | — | — | ||
It is possible for a user in a different organization from the owner of a snapshot to bypass authorization and delete a snapshot by issuing a DELETE request to /api/snapshots/<key>… | ||||
| CVE-2024-28834US | —OT elevated | — | ||
A flaw was found in GnuTLS. The Minerva attack is a cryptographic vulnerability that exploits deterministic behavior in systems like GnuTLS, leading to side-channel leaks. In speci… | ||||
| CVE-2024-1394US | — | — | ||
A memory leak flaw was found in Golang in the RSA encrypting/decrypting code, which might lead to a resource exhaustion vulnerability using attacker-controlled inputs. The memory… | ||||
| CVE-2024-28835US | — | — | ||
A flaw has been discovered in GnuTLS where an application crash can be induced when attempting to verify a specially crafted .pem bundle using the "certtool --verify-chain" command… | ||||
| CVE-2024-0450US | — | — | ||
An issue was found in the CPython `zipfile` module affecting versions 3.12.1, 3.11.7, 3.10.13, 3.9.18, and 3.8.18 and prior.
The zipfile module is vulnerable to “quoted-overlap” z… | ||||
| CVE-2023-6597US | — | — | ||
An issue was found in the CPython `tempfile.TemporaryDirectory` class affecting versions 3.12.1, 3.11.7, 3.10.13, 3.9.18, and 3.8.18 and prior.
The tempfile.TemporaryDirectory cla… | ||||
| CVE-2024-24786US | — | — | ||
The protojson.Unmarshal function can enter an infinite loop when unmarshaling certain forms of invalid JSON. This condition can occur when unmarshaling into a message which contain… | ||||
| CVE-2024-26461US | — | — | ||
Kerberos 5 (aka krb5) 1.21.2 contains a memory leak vulnerability in /krb5/src/lib/gssapi/krb5/k5sealv3.c. | ||||
| CVE-2024-26458US | — | — | ||
Kerberos 5 (aka krb5) 1.21.2 contains a memory leak in /krb5/src/lib/rpc/pmap_rmt.c. | ||||
| CVE-2022-48624US | high7.8 | — | ||
close_altfile in filename.c in less before 606 omits shell_quote calls for LESSCLOSE. | ||||
| CVE-2023-50868US | high7.5 | Exploit | ||
The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance is skipped) allows remote attackers to cause a denial of service (CPU consumption for SHA-… | ||||
| CVE-2023-50387US | high7.5 | Exploit | ||
Certain DNSSEC aspects of the DNS protocol (in RFC 4033, 4034, 4035, 6840, and related RFCs) allow remote attackers to cause a denial of service (CPU consumption) via one or more D… | ||||
| CVE-2023-6516US | — | — | ||
To keep its cache database efficient, `named` running as a recursive resolver occasionally attempts to clean up the database. It uses several methods, including some that are async… | ||||
showing 20 of 60
02
references
External citations — patches, advisories, analysis.
- Red Hat Security Advisory RHSA-2024:1616 vom 2024-07-01external
- Red Hat Security Advisory RHSA-2024:3314 vom 2024-06-13external
- Red Hat Security Advisory RHSA-2024:3680 vom 2024-06-06external
- Red Hat Security Advisory RHSA-2024:3683 vom 2024-06-06external
- Red Hat Security Advisory RHSA-2024:3790 vom 2024-06-11external
- Red Hat Security Advisory RHSA-2024:4553 vom 2024-07-16external
- Red Hat Security Advisory RHSA-2024:7184 vom 2024-10-03external
- Red Hat Security Advisory RHSA-2024:8688 vom 2024-11-06external
scry
Advisories like this name the exposed products attackers go after on your perimeter. See what is exposed on your perimeter with a free passive scan.
Free scan