ICSA-25-030-04

icsaUScisa_csaf_ot

Rockwell Automation KEPServer

view advisory published 2025-01-30

Successful exploitation of this vulnerability could cause the device to crash.

01

describes (1)

Related CVEs.

IDseverity exploitable
CVE-2023-3825UShigh7.5—
PTC’s KEPServerEX Versions 6.0 to 6.14.263 are vulnerable to being made to read a recursively defined object that leads to uncontrolled resource consumption. KEPServerEX uses OPC…
02

references

External citations — patches, advisories, analysis.

03

remediations (2)

  • MitigationKEPServer

    Rockwell Automation also encourages users using the affected software to apply the following risk mitigations, if possible.

  • FixedKEPServer

    Rockwell automation recommends that users upgrade to KEPServer Version 6.15 or higher.

scry

Advisories like this name the exposed products attackers go after on your perimeter. See what is exposed on your perimeter with a free passive scan.

Free scan