CVE-2026-75925
criticalpriority · track · 0EPSS 0.007 · 52 %ileDEUSEPSS · scored 2026-10-27
Improper neutralization of CRLF sequences in IXON VPN Client before version 1.4.7 allows an attacker to execute commands as root or SYSTEM. Configuration values accepted by the local service are written to a file later consumed by a privileged subprocess, without line-ending sequences being neutralized, which allows additional directives to be introduced into that file. The configuration interface accepts changes without authenticating or verifying the origin of the requester. The injected configuration persists on disk across restarts of the client and the operating system, and the VPN connection continues to function normally, so there is no behavioral change visible to the user.
remediations
Vendor fix, mitigation, or workaround guidance, as published by each source.
A vendor fix is available.
- FixedLenze VPN Client <1.4.7lenze_psirt
The Lenze VPN Client is available and downloadable via the Fleet Manager. Please update this Client. Obtain the update software (version >= 1.4.7) from https://cloud.lenze.digital/fleet-manager/tools and run the installer on a windows and macOS system or run the following commands in an linux system: ``` tar -xzf vpn_client_x64.tar.gz cd vpn_client_x64 sudo ./install ```
- MitigationLenze VPN Client <1.4.7lenze_psirt
As the cloud environment blocks older versions of the Lenze VPN Client, you must update the Lenze VPN Client. If you attempt to connect to the VPN using an older version, an error message will appear stating: "A newer version of the VPN client is required."
- MitigationVPN Clientcisa_csaf_ot
As of August 5, 2026, IXON cloud rejects connections from clients below v1.4.7 at both the portal and the back-end API. Since the privileged subprocess and injected listener are only created when the client connects, unpatched installations cannot complete the exploit chain.
cvss
Technical severity, 0–10. One row per scoring source.
base score 0–10 · higher = more severe · hover a vector to decode⚠ sources disagree · high–critical · 7.7–9.6
ssvc
A stakeholder decision — act, attend, or track — from exploitation and impact.
weaknesses
The CWE weakness classes this flaw belongs to.
affected products (3)
Products and version ranges known to be affected.
- Lenze VPN Client <1.4.7≤ vers:semver/>=1.0.0|<1.4.7lenze_psirtDEcpe:2.3:a:lenze:vpnclient:*:*:*:*:*:*:*:*
advisories (2)
Vendor and ecosystem advisories describing this.
- VDE-2026-089Lenze: VPN Client Remote Code Execution in combination with Lenze x500 IoT Gateway2026-09-21csaf · lenze_psirtDE
The Lenze VPN client is vulnerable to a Remote Code Execution. The vulnerability would allow an attacker to perform a remote code execution on the computer running the client with elevated privileges.
- ICSA-26-246-02IXON VPN Client2026-08-05icsa · cisa_csaf_otUS
Successful exploitation of this vulnerability could allow an attacker to perform remote code execution on the computer running the client with elevated privileges.
sources
Which sources assert this record, and when.
references (3) nvd
External citations — patches, advisories, analysis.
Attackers weaponise vulnerabilities like this against internet-exposed services. See what is exposed on your perimeter with a free passive scan.
Free scan