CVE-2026-59898
highpriority · track · 30EPSS 0.004 · 37 %ileDEEUUSEPSS · scored 2026-10-22
Netty is an asynchronous, event-driven network application framework. Prior to versions 4.1.136.Final and 4.2.16.Final, ab attacker can force WebSocket upgrade via the lax V07 (or V08) handshaker by sending `Sec-WebSocket-Version: 7` and omitting `Connection: Upgrade` / `Upgrade: websocket` headers, completing a protocol switch that a proxy would not recognize as an Upgrade request and enabling HTTP request smuggling / protocol-confusion attacks. This issue has been fixed in versions 4.1.136.Final and 4.2.16.Final.
remediations
Vendor fix, mitigation, or workaround guidance, as published by each source.
A vendor fix is available.
- FixedCorivaEnginesick_psirt
Users are recommended to upgrade to version 2026.1.1.
cvss
Technical severity, 0–10. One row per scoring source.
base score 0–10 · higher = more severe · hover a vector to decode⚠ sources disagree · low–high · 1.7–7.5
ssvc
A stakeholder decision — act, attend, or track — from exploitation and impact.
weaknesses
The CWE weakness classes this flaw belongs to.
affected products (20)
Products and version ranges known to be affected.
- IBM App Connect Enterprise for Manufactoringall versionscert_bundDEcpe:/a:ibm:app_connect_enterprise:for_manufactoring
advisories (3)
Vendor and ecosystem advisories describing this.
- WID-SEC-W-2026-2356Netty: Mehrere SchwachstellenDeutsch2026-07-14csaf · cert_bundDE
Ein Angreifer kann mehrere Schwachstellen in Netty ausnutzen, um Sicherheitsprüfungen zu umgehen, Anfragen oder Header zu manipulieren, Zertifikatsprüfungen zu unterlaufen sowie einen Denial of Service zu verursachen.
- sca-2026-0013Vulnerabilities Affecting SICK CorivaEngine2026-09-11csaf · sick_psirtDE
SICK CorivaEngine includes the third-party components Netty and Spring Cloud Gateway that are affected by multiple known vulnerabilities. Under certain conditions, these vulnerabilities could allow remote attackers to perform HTTP request smuggling, cause resource exhaustion, or manipulate forwarded request headers. Successful exploitation may impact the integrity and availability of affected systems. SICK has addressed these vulnerabilities and recommends that customers apply the remediations described in this Security Advisory.
- GHSA-4mp9-239f-g9hgNetty: WebSockets V07/V08 handshaker missing Connection/Upgrade validation2026-07-22ghsa · osvUS
## Summary An attacker can force WebSocket upgrade via the lax V07 (or V08) handshaker by sending `Sec-WebSocket-Version: 7` and omitting `Connection: Upgrade` / `Upgrade: websocket` headers, completing a protocol switch that a proxy would not recognize as an Upgrade request and enabling HTTP request smuggling / protocol-confusion attacks.
also known as (3)
Other names and identifiers for this entity.
sources
Which sources assert this record, and when.
references (9)
External citations — patches, advisories, analysis.
- https://github.com/netty/netty/releases/tag/netty-4.1.136.Finalcnnvd
- https://github.com/netty/netty/releases/tag/netty-4.2.16.Finalcnnvd
- https://github.com/netty/netty/security/advisories/GHSA-4mp9-239f-g9hgcnnvd
- https://github.com/netty/netty/releases/tag/netty-4.1.136.Finalenisa_euvd
- https://github.com/netty/netty/releases/tag/netty-4.2.16.Finalenisa_euvd
- https://github.com/netty/netty/security/advisories/GHSA-4mp9-239f-g9hgenisa_euvd
- https://github.com/netty/netty/releases/tag/netty-4.1.136.FinalRelease Notesnvd
- https://github.com/netty/netty/releases/tag/netty-4.2.16.FinalRelease Notesnvd
Attackers weaponise vulnerabilities like this against internet-exposed services. See what is exposed on your perimeter with a free passive scan.
Free scan