CVE-2026-55957
highpriority · track · 11EPSS 0.029 · 87 %ileexploit · PoCDEEURUUSEPSS · scored 2026-10-27
Missing Critical Step in Authentication vulnerability in Apache Tomcat when the JNDIRealm was configured to authenticate binds using GSSAPI allowed attackers to authenticate without provided the correct password. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.4, from 10.1.0-M1 through 10.1.36, from 9.0.0.M1 through 9.0.100, from 8.5.0 through 8.5.100, from 7.0.0 through 7.0.109. Users are recommended to upgrade to version 11.0.5, 10.1.37 or 9.0.101, which fixes the issue.
cvss
Technical severity, 0–10. One row per scoring source.
base score 0–10 · higher = more severe · hover a vector to decode⚠ sources disagree · medium–high · 6.9–7.3
ssvc
A stakeholder decision — act, attend, or track — from exploitation and impact.
weaknesses
The CWE weakness classes this flaw belongs to.
exploits (1)
Public proof-of-concept and weaponised exploit code.
affected products (39)
Products and version ranges known to be affected.
- IBM Power Hardware Management Console V10.3.1050.0-V10.3.1064.1all versionscert_bundDEcpe:/a:ibm:hardware_management_console:v10.3.1050.0_-_v10.3.1064.1
- IBM Power Hardware Management Console V11.1.1110.0-V11.1.1112.2all versionscert_bundDEcpe:/a:ibm:hardware_management_console:v11.1.1110.0_-_v11.1.1112.2
- IBM Power Hardware Management Console V11.2.1120.0all versionscert_bundDEcpe:/a:ibm:hardware_management_console:v11.2.1120.0
advisories (2)
Vendor and ecosystem advisories describing this.
- WID-SEC-W-2026-2123Apache Tomcat: Mehrere SchwachstellenDeutsch2026-06-29csaf · cert_bundDE
Ein Angreifer kann mehrere Schwachstellen in Apache Tomcat ausnutzen, um Sicherheitsmaßnahmen zu umgehen, einen Denial-of-Service-Zustand zu verursachen, Cross-Site-Scripting-Angriffe durchzuführen oder andere, nicht näher spezifizierte Auswirkungen auszulösen.
- BIT-tomcat-2026-55957Apache Tomcat: Authentication bypass with JNDIRealm and GSSAPI authenticated bind2026-09-11vendor · osvUS
Missing Critical Step in Authentication vulnerability in Apache Tomcat when the JNDIRealm was configured to authenticate binds using GSSAPI allowed attackers to authenticate without provided the correct password. This issue affects Apache Tomcat: from 11.0.0 through 11.0.4, from 10.1.0 through 10.1.36, from 9.0.0 through 9.0.100, from 8.5.0 through 8.5.100, from 7.0.0 through 7.0.109. Users are recommended to upgrade to version 11.0.5, 10.1.37 or 9.0.101, which fixes the issue.
also known as (4)
Other names and identifiers for this entity.
sources
Which sources assert this record, and when.
references (6)
External citations — patches, advisories, analysis.
- http://www.openwall.com/lists/oss-security/2026/06/29/26cnnvd
- https://lists.apache.org/thread/7fk339o5jvd4mcgsf0chbrn4o525ccjhcnnvd
- https://tomcat.apache.org/Patchcnnvd
- https://lists.apache.org/thread/7fk339o5jvd4mcgsf0chbrn4o525ccjhenisa_euvd
- http://www.openwall.com/lists/oss-security/2026/06/29/26Third Party Advisorynvd
- https://lists.apache.org/thread/7fk339o5jvd4mcgsf0chbrn4o525ccjhVendor AdvisoryMailing Listnvd
Attackers weaponise vulnerabilities like this against internet-exposed services. See what is exposed on your perimeter with a free passive scan.
Free scan