CVE-2026-47762
mediumpriority · track · 22EPSS 0.003 · 21 %ileDEEUFRUSEPSS · scored 2026-10-27
TinyMCE is an open source rich text editor. Prior to 5.11.1, 7.9.3, and 8.5.1, there is a stored XSS vulnerability via forged mce:protected comments. Allows attackers to bypass sanitization and inject scripts that execute when content is restored. Impacts users who utilize the protect option. This vulnerability is fixed in 5.11.1, 7.9.3, and 8.5.1.
cvss
Technical severity, 0–10. One row per scoring source.
base score 0–10 · higher = more severe · hover a vector to decode⚠ sources disagree · medium–high · 5–8.7
ssvc
A stakeholder decision — act, attend, or track — from exploitation and impact.
weaknesses
The CWE weakness classes this flaw belongs to.
affected products (34)
Products and version ranges known to be affected.
advisories (3)
Vendor and ecosystem advisories describing this.
- WID-SEC-W-2026-3376Atlassian Bamboo, Bitbucket, Confluence, Fisheye/Crucible, Jira Software und Jira Service Management: Mehrere SchwachstellenDeutsch2026-09-15csaf · cert_bundDE
Ein Angreifer kann mehrere Schwachstellen in Atlassian Bamboo, Bitbucket, Confluence, Fisheye/Crucible, Jira Software und Jira Service Management ausnutzen, um beliebigen Programmcode auszuführen, Sicherheitsmaßnahmen zu umgehen, serverseitige Request-Forgery-Angriffe (SSRF) durchzuführen, Cross-Site-Scripting-Angriffe zu starten, sensible Informationen offenzulegen, Daten zu manipulieren oder Denial-of-Service-Zustände herbeizuführen.
- GHSA-v98h-vmpc-fpqvTinyMCE Cross-Site Scripting (XSS) vulnerability through `mce:protected` comments2026-06-05ghsa · osvUS
### Impact Stored XSS vulnerability via forged mce:protected comments. Allows attackers to bypass sanitization and inject scripts that execute when content is restored. Impacts users who utilize the protect option. ### Patches Patched by validating decoded mce:protected content against configured protect regex rules before restoring. Users should upgrade to the latest patched version. ### Workarounds No official workaround available. ### Fix To avoid this vulnerability: Upgrade to TinyMCE 8.5.1 or higher. Upgrade to TinyMCE 7.9.3 or higher. Upgrade to TinyMCE 5.11.1 LTS or higher for TinyMCE 5.x (only available as part of commercial [long-term support](https://www.tiny.cloud/long-term-support/) contract). ### Acknowledgements Tiny thanks [Ivan Babenko](https://github.com/he1d3n) for their help identifying this vulnerability.
- CERTFR-2026-AVI-1318Multiples vulnérabilités dans MoodleFrançais2026-10-15vendor · certfrFR
also known as (3)
Other names and identifiers for this entity.
sources
Which sources assert this record, and when.
references (10)
External citations — patches, advisories, analysis.
- https://github.com/tinymce/tinymce/security/advisories/GHSA-v98h-vmpc-fpqvcnnvd
- https://github.com/tinymce/tinymce/tagsPatchcnnvd
- https://www.tiny.cloud/docs/tinymce/7/7.9.3-release-notes/#overviewcnnvd
- https://www.tiny.cloud/docs/tinymce/8/8.5.1-release-notes/#overviewcnnvd
- https://github.com/tinymce/tinymce/security/advisories/GHSA-v98h-vmpc-fpqvenisa_euvd
- https://www.tiny.cloud/docs/tinymce/7/7.9.3-release-notes/#overviewenisa_euvd
- https://www.tiny.cloud/docs/tinymce/8/8.5.1-release-notes/#overviewenisa_euvd
- https://github.com/tinymce/tinymce/security/advisories/GHSA-v98h-vmpc-fpqvVendor Advisorynvd
Attackers weaponise vulnerabilities like this against internet-exposed services. See what is exposed on your perimeter with a free passive scan.
Free scan