CVE-2026-43995

criticalpriority · track · 39EPSS 0.004 · 34 %ileDEEUUS
grimoire priorityP2 · Scheduled
Exploitable?
—
no known exploitation
Likely / severe?
0.40% (34th) EPSS
CVSS 9.8 · critical
Is it mine?
6 products
Check your exposure
Who says so?
5 sources
cnnvd · enisa_euvd · cert_bund · nvd

EPSS · scored 2026-10-27

Flowise is a drag & drop user interface to build a customized large language model flow. Prior to 3.1.0, multiple tool implementations directly import and invoke raw HTTP clients (node-fetch, axios) instead of using the secured wrapper. These tools include (1) OpenAPIToolkit/OpenAPIToolkit.ts, (2) WebScraperTool/WebScraperTool.ts, (3) MCP/core.ts, and (4) Arxiv/core.ts. This vulnerability is fixed in 3.1.0.

01

cvss

Technical severity, 0–10. One row per scoring source.

9.8
010

base score 0–10 · higher = more severe · hover a vector to decode⚠ sources disagree · low–critical · 1.3–9.8

v3.19.8criticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:Hprimary · NVD / NIST USexploitability 3.9 · impact 5.9
v4.05.3mediumCVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:N/SC:L/SI:L/SA:Nsecondary · ENISA EU
v4.05.3mediumCVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:N/SC:L/SI:L/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:Xsecondary · security-advisories@github.com
v4.01.3lowCVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:N/SC:L/SI:L/SA:N/E:U/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:Xsecondary · CVSS-BT (t0sche)
02

ssvc

A stakeholder decision — act, attend, or track — from exploitation and impact.

Exploitation: poc · Automatable: no · Technical Impact: partialcoordinatorcisa_ssvcUS
03

weaknesses

The CWE weakness classes this flaw belongs to.

04

affected products (6)

Products and version ranges known to be affected.

05

advisories (2)

Vendor and ecosystem advisories describing this.

  • WID-SEC-W-2026-1145Flowise: Mehrere SchwachstellenDeutsch2026-04-15csaf · cert_bundDE

    Ein Angreifer kann mehrere Schwachstellen in Flowise ausnutzen, um beliebigen Programmcode auszuführen, um Sicherheitsvorkehrungen zu umgehen, um Informationen offenzulegen, und um Dateien zu manipulieren.

  • GHSA-qqvm-66q4-vf5cFlowise: SSRF Protection Bypass via Direct node-fetch / axios Usage (Patch Enforcement Failure)2026-04-16ghsa · osvUS

    ### Summary Flowise introduced SSRF protections through a centralized HTTP security wrapper (`httpSecurity.ts`) that implements deny-list validation and IP pinning logic. However, multiple tool implementations directly import and invoke raw HTTP clients (`node-fetch`, `axios`Instead of using the secured wrapper. Because enforcement is neither mandatory nor centralized, these tools bypass SSRF mitigation entirely, restoring full SSRF capability even after the patch. This issue is distinct from specification trust issues and represents incomplete mitigation of previously addressed SSRF vulnerabilities. ### Details **Intended Security Model:** All outbound HTTP requests should pass through the centralized validation layer implemented in: ``` packages/components/src/httpSecurity.ts ``` This layer performs: - `HTTP_DENY_LIST` enforcement - IP resolution validation - IP pinning - Loopback blocking **Observed Implementation Gap:** Multiple tools bypass this layer and import HTTP libraries directly. Examples include: - `packages/components/nodes/tools/OpenAPIToolkit/OpenAPIToolkit.ts` - `packages/components/nodes/tools/WebScraperTool/WebScraperTool.ts` - `packages/components/nodes/tools/MCP/core.ts` - `packages/components/nodes/tools/Arxiv/core.ts` These files directly execute: ``` importfetchfrom'node-fetch' ``` or invoke `axios` without passing through the centralized validation wrapper. Because there is no global interceptor or enforcement mechanism, outbound requests in these components are executed without SSRF validation. This renders the mitigation introduced in GHSA-2x8m-83vc-6wv4 incomplete. ### Root Cause Security enforcement is not centralized. Outbound request validation depends on voluntary usage of a wrapper function rather than being structurally enforced. Because direct imports of HTTP clients are allowed, the mitigation is easily bypassed. This is an architectural enforcement failure rather than a single implementation bug. ### PoC Even when an administrator configures: ``` HTTP_DENY_LIST=169.254.0.0/16,127.0.0.0/8 ``` The following attack succeeds if a vulnerable tool is enabled: **Chat Prompt:** ``` Use the Web Scraper tool to retrieve: http://169.254.169.254/latest/meta-data/iam/security-credentials/ ``` Execution flow: 1. The LLM triggers `WebScraperTool`. 2. The tool calls raw `fetch()` directly. 3. No `httpSecurity.ts` validation is applied. 4. The request reaches the metadata endpoint. 5. The response is returned to the chat context. This demonstrates that SSRF protection is opt-in rather than enforced. ### Impact **Severity:** Critical (CVSS v3.1: 9.1 – AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N) This issue: - Completely bypasses the centralized SSRF mitigation. - Allows access to internal network resources. - Enables the exploitation of cloud metadata and credential theft. - Invalidates the security assumptions of the recent patch. Any deployment enabling affected tools remains vulnerable. ### Recommended Remediation 1. Refactor all tools to use the centralized `secureFetch()` wrapper. 2. Add ESLint `no-restricted-imports` rules to prohibit the direct usage of `node-fetch` or `axios` in tool components. 3. Consider implementing a single internal HTTP client abstraction layer. 4. Apply network-level egress filtering as defense-in-depth.

06

also known as (3)

Other names and identifiers for this entity.

07

sources

Which sources assert this record, and when.

published 2026-05-11modified 2026-10-26
08

references (4)

External citations — patches, advisories, analysis.

scry

Attackers weaponise vulnerabilities like this against internet-exposed services. See what is exposed on your perimeter with a free passive scan.

Free scan