CVE-2026-35479
mediumpriority · track · 19EPSS 0.002 · 12 %ileEUUSEPSS · scored 2026-10-28
InvenTree is an Open Source Inventory Management System. Prior to 1.2.7 and 1.3.0, any users who have staff access permissions can install plugins via the API, without requiring "superuser" account access. This level of permission requirement is out of alignment with other plugin actions (such as uninstalling) which do require superuser access. The vulnerability allows staff users (who may be considered to have a lower level of trust than a superuser account) to install arbitrary (and potentially harmful) plugins. This vulnerability is fixed in 1.2.7 and 1.3.0.
cvss
Technical severity, 0–10. One row per scoring source.
base score 0–10 · higher = more severe · hover a vector to decode
ssvc
A stakeholder decision — act, attend, or track — from exploitation and impact.
weaknesses
The CWE weakness classes this flaw belongs to.
affected products (2)
Products and version ranges known to be affected.
also known as (2)
Other names and identifiers for this entity.
sources
Which sources assert this record, and when.
references (10)
External citations — patches, advisories, analysis.
- https://docs.inventree.org/en/stable/concepts/threat_model/#assumed-trustcnnvd
- https://docs.inventree.org/en/stable/start/config/#plugin-optionscnnvd
- https://github.com/inventree/InvenTree/releasesPatchcnnvd
- https://github.com/inventree/InvenTree/security/advisories/GHSA-7c3q-vwcv-2vp7cnnvd
- https://docs.inventree.org/en/stable/concepts/threat_model/#assumed-trustenisa_euvd
- https://docs.inventree.org/en/stable/start/config/#plugin-optionsenisa_euvd
- https://github.com/inventree/InvenTree/security/advisories/GHSA-7c3q-vwcv-2vp7enisa_euvd
- https://docs.inventree.org/en/stable/concepts/threat_model/#assumed-trustProductnvd
Attackers weaponise vulnerabilities like this against internet-exposed services. See what is exposed on your perimeter with a free passive scan.
Free scan