CVE-2026-33997
highpriority · track · 32EPSS 0.004 · 33 %ileDEEUFRRUUSEPSS · scored 2026-10-27
Moby is an open source container framework. Prior to version 29.3.1, a security vulnerability has been detected that allows plugins privilege validation to be bypassed during docker plugin install. Due to an error in the daemon's privilege comparison logic, the daemon may incorrectly accept a privilege set that differs from the one approved by the user. Plugins that request exactly one privilege are also affected, because no comparison is performed at all. This issue has been patched in version 29.3.1.
cvss
Technical severity, 0–10. One row per scoring source.
base score 0–10 · higher = more severe · hover a vector to decode⚠ sources disagree · medium–high · 6.8–8.4
ssvc
A stakeholder decision — act, attend, or track — from exploitation and impact.
weaknesses
The CWE weakness classes this flaw belongs to.
affected products (25)
Products and version ranges known to be affected.
- Red Hat OpenShift API for Data Protectionall versionscert_bundDEcpe:/a:redhat:openshift:api_for_data_protection
advisories (4)
Vendor and ecosystem advisories describing this.
- WID-SEC-W-2026-0873docker: Mehrere SchwachstellenDeutsch2026-03-25csaf · cert_bundDE
Ein lokaler Angreifer kann mehrere Schwachstellen in docker ausnutzen, um Sicherheitsvorkehrungen zu umgehen und Informationen offenzulegen.
- GHSA-pxq6-2prw-chj9Moby has an Off-by-one error in its plugin privilege validation2026-03-27ghsa · osvUS
## Summary A security vulnerability has been detected that allows [plugins](https://docs.docker.com/engine/extend/legacy_plugins/) privilege validation to be bypassed during `docker plugin install`. Due to an error in the daemon's privilege comparison logic, the daemon may incorrectly accept a privilege set that differs from the one approved by the user. Plugins that request exactly one privilege are also affected, because no comparison is performed at all. ## Impact **If plugins are not in use, there is no impact.** When a plugin is installed, the daemon computes the privileges required by the plugin's configuration and compares them with the privileges approved during installation. A malicious plugin can exploit this bug so that the daemon accepts privileges that differ from what was intended to be approved. Anyone who depends on the plugin installation approval flow as a meaningful security boundary is potentially impacted. Depending on the privilege set involved, this may include highly sensitive plugin permissions such as broad device access. **For consideration: exploitation still requires a plugin to be installed from a malicious source, and Docker plugins are relatively uncommon. Docker Desktop also does not support plugins.** ## Workarounds If unable to update immediately: - Do not install plugins from untrusted sources - Carefully review all privileges requested during `docker plugin install` - Restrict access to the Docker daemon to trusted parties, following the principle of least privilege - Avoid relying on plugin privilege approval as the only control boundary for sensitive environments ## Credits - Reported by Cody (c@wormhole.guru, PGP 0x9FA5B73E)
- CERTFR-2026-AVI-1336Multiples vulnérabilités dans les produits IBMFrançais2026-10-16vendor · certfrFR
- GO-2026-4883Moby has an Off-by-one error in its plugin privilege validation in github.com/docker/docker2026-04-02vendor · osvUS
Moby has an Off-by-one error in its plugin privilege validation in github.com/docker/docker
also known as (6)
Other names and identifiers for this entity.
sources
Which sources assert this record, and when.
references (14)
External citations — patches, advisories, analysis.
- https://github.com/moby/moby/releasesPatchcnnvd
- https://github.com/moby/moby/releases/tag/docker-v29.3.1cnnvd
- https://github.com/moby/moby/security/advisories/GHSA-pxq6-2prw-chj9cnnvd
- https://vigilance.fr/vulnerability/Docker-Moby-privilege-escalation-via-Plugin-Privilege-Validation-50201cnnvd
- https://github.com/moby/moby/releases/tag/docker-v29.3.1enisa_euvd
- https://github.com/moby/moby/security/advisories/GHSA-pxq6-2prw-chj9enisa_euvd
- https://access.redhat.com/errata/RHSA-2026:21769nvd
- https://access.redhat.com/errata/RHSA-2026:22347nvd
Attackers weaponise vulnerabilities like this against internet-exposed services. See what is exposed on your perimeter with a free passive scan.
Free scan