CVE-2026-33762

lowpriority · track · 0EPSS 0.002 · 4 %ileEUFRRUUS
grimoire priorityP3 · Track
Exploitable?
—
no known exploitation
Likely / severe?
0.15% (4th) EPSS
CVSS 2.8 · low
Is it mine?
31 products
Check your exposure
Who says so?
5 sources
cnnvd · enisa_euvd · fstec_bdu · osv

EPSS · scored 2026-10-27

go-git is an extensible git implementation library written in pure Go. Prior to version 5.17.1, go-git’s index decoder for format version 4 fails to validate the path name prefix length before applying it to the previously decoded path name. A maliciously crafted index file can trigger an out-of-bounds slice operation, resulting in a runtime panic during normal index parsing. This issue only affects Git index format version 4. Earlier formats (go-git supports only v2 and v3) are not vulnerable to this issue. This issue has been patched in version 5.17.1.

01

cvss

Technical severity, 0–10. One row per scoring source.

2.8
010

base score 0–10 · higher = more severe · hover a vector to decode

v3.12.8lowAV:L/AC:L/PR:L/UI:R/S:U/C:N/I:N/A:Lsecondary · FSTEC (BDU) RU
v3.12.8lowCVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:N/I:N/A:Lsecondary · ENISA EU
v3.12.8lowCVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:N/I:N/A:Lsecondary · security-advisories@github.comexploitability 1.3 · impact 1.4
v3.12.8lowCVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:N/I:N/A:Lsecondary · OSV
v3.12.6lowCVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:N/I:N/A:L/E:Usecondary · CVSS-BT (t0sche)
02

ssvc

A stakeholder decision — act, attend, or track — from exploitation and impact.

Trackcoordinatorcisa_ssvcUS
03

weaknesses

The CWE weakness classes this flaw belongs to.

04

affected products (31)

Products and version ranges known to be affected.

05

advisories (3)

Vendor and ecosystem advisories describing this.

  • GHSA-gm2x-2g9h-ccm8go-git missing validation decoding Index v4 files leads to panic2026-03-30ghsa · osvUS

    ### Impact `go-git`’s index decoder for format version 4 fails to validate the path name prefix length before applying it to the previously decoded path name. A maliciously crafted index file can trigger an out-of-bounds slice operation, resulting in a runtime panic during normal index parsing. This issue only affects Git index format version 4. Earlier formats (`go-git` supports only `v2` and `v3`) are not vulnerable to this issue. An attacker able to supply a crafted `.git/index` file can cause applications using go-git to panic while reading the index. If the application does not recover from panics, this results in process termination, leading to a denial-of-service (DoS) condition. Exploitation requires the ability to modify or inject a Git index file within the local repository in disk. This typically implies write access to the `.git` directory. ### Patches Users should upgrade to `v5.17.1`, or the latest `v6` [pseudo-version](https://go.dev/ref/mod#pseudo-versions), in order to mitigate this vulnerability. ### Credit go-git maintainers thank @kq5y for finding and reporting this issue privately to the `go-git` project.

  • CERTFR-2026-AVI-1385Multiples vulnérabilités dans les produits VMwareFrançais2026-10-26vendor · certfrFR
  • GO-2026-4909Missing validation decoding Index v4 files leads to panic in github.com/go-git/go-git2026-04-07vendor · osvUS

    Missing validation decoding Index v4 files leads to panic in github.com/go-git/go-git

06

also known as (5)

Other names and identifiers for this entity.

07

sources

Which sources assert this record, and when.

published 2026-03-31modified 2026-08-05
08

references (7)

External citations — patches, advisories, analysis.

scry

Attackers weaponise vulnerabilities like this against internet-exposed services. See what is exposed on your perimeter with a free passive scan.

Free scan