CVE-2026-33412

highpriority · track · 29EPSS 0.009 · 59 %ileDEEUUS
grimoire priorityP2 · Scheduled
Exploitable?
—
no known exploitation
Likely / severe?
0.87% (59th) EPSS
CVSS 7.3 · high
Is it mine?
16 products
Check your exposure
Who says so?
5 sources
cnnvd · enisa_euvd · cert_bund · nvd

EPSS · scored 2026-10-27

Vim is an open source, command line text editor. Prior to version 9.2.0202, a command injection vulnerability exists in Vim's glob() function on Unix-like systems. By including a newline character (\n) in a pattern passed to glob(), an attacker may be able to execute arbitrary shell commands. This vulnerability depends on the user's 'shell' setting. This issue has been patched in version 9.2.0202.

01

remediations

Vendor fix, mitigation, or workaround guidance, as published by each source.

A vendor fix is available.

  • Fixedvim-X11-2:8.2.2637-22.el9_6.2.x86_64 as component of SUSE Liberty Linux 9.6 EMSsuse_csaf

    To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".

  • Fixedvim-common-2:8.2.2637-22.el9_6.2.x86_64 as component of SUSE Liberty Linux 9.6 EMSsuse_csaf

    To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".

  • Fixedvim-enhanced-2:8.2.2637-22.el9_6.2.x86_64 as component of SUSE Liberty Linux 9.6 EMSsuse_csaf

    To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".

  • Fixedvim-filesystem-2:8.2.2637-22.el9_6.2.noarch as component of SUSE Liberty Linux 9.6 EMSsuse_csaf

    To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".

  • Fixedvim-minimal-2:8.2.2637-22.el9_6.2.x86_64 as component of SUSE Liberty Linux 9.6 EMSsuse_csaf

    To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".

  • Fixedvim-X11-2:7.4.629-8.el7_9.1.x86_64 as component of SUSE Liberty Linux 7 LTSSsuse_csaf

    To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".

  • Fixedvim-common-2:7.4.629-8.el7_9.1.x86_64 as component of SUSE Liberty Linux 7 LTSSsuse_csaf

    To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".

  • Fixedvim-enhanced-2:7.4.629-8.el7_9.1.x86_64 as component of SUSE Liberty Linux 7 LTSSsuse_csaf

    To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".

  • Fixedvim-filesystem-2:7.4.629-8.el7_9.1.x86_64 as component of SUSE Liberty Linux 7 LTSSsuse_csaf

    To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".

  • Fixedvim-minimal-2:7.4.629-8.el7_9.1.x86_64 as component of SUSE Liberty Linux 7 LTSSsuse_csaf

    To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".

  • Fixedvim-X11-2:8.0.1763-22.el8_10.1.x86_64 as component of SUSE Liberty Linux 8suse_csaf

    To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".

  • Fixedvim-common-2:8.0.1763-22.el8_10.1.x86_64 as component of SUSE Liberty Linux 8suse_csaf

    To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".

  • Fixedvim-enhanced-2:8.0.1763-22.el8_10.1.x86_64 as component of SUSE Liberty Linux 8suse_csaf

    To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".

  • Fixedvim-filesystem-2:8.0.1763-22.el8_10.1.noarch as component of SUSE Liberty Linux 8suse_csaf

    To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".

  • Fixedvim-minimal-2:8.0.1763-22.el8_10.1.x86_64 as component of SUSE Liberty Linux 8suse_csaf

    To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".

02

cvss

Technical severity, 0–10. One row per scoring source.

7.3
010

base score 0–10 · higher = more severe · hover a vector to decode⚠ sources disagree · medium–high · 5.3–7.3

v3.17.3highCVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:Hprimary · NVD / NIST USexploitability 1.3 · impact 5.9
v3.15.6mediumCVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:L/I:H/A:Nsecondary · ENISA EU
v3.15.6mediumCVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:L/I:H/A:Nsecondary · security-advisories@github.comexploitability 1.3 · impact 4.2
v3.17.3highCVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:Hsecondaryexploitability 1.3 · impact 5.9
v3.16.7mediumCVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H/E:Usecondary · CVSS-BT (t0sche)
v3.15.3mediumCVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:U/C:L/I:H/A:Nsecondary · SUSE Product Security
03

ssvc

A stakeholder decision — act, attend, or track — from exploitation and impact.

Exploitation: none · Automatable: no · Technical Impact: totalcoordinatorcisa_ssvcUS
04

weaknesses

The CWE weakness classes this flaw belongs to.

05

affected products (16)

Products and version ranges known to be affected.

06

advisories (5)

Vendor and ecosystem advisories describing this.

07

also known as (2)

Other names and identifiers for this entity.

08

sources

Which sources assert this record, and when.

09

references (47)

External citations — patches, advisories, analysis.

scry

Attackers weaponise vulnerabilities like this against internet-exposed services. See what is exposed on your perimeter with a free passive scan.

Free scan