CVE-2026-33229
criticalpriority · track · 10OT risk · elevatedEPSS 0.005 · 45 %ileexploit · PoCDEEURUUSEPSS · scored 2026-10-27
XWiki Platform is a generic wiki platform offering runtime services for applications built on top of it. Prior to 17.4.8 and 17.10.1, an improperly protected scripting API allows any user with script right to bypass the sandboxing of the Velocity scripting API and execute, e.g., arbitrary Python scripts, allowing full access to the XWiki instance and thereby compromising the confidentiality, integrity and availability of the whole instance. Note that script right already constitutes a high level of access that we don't recommend giving to untrusted users. This vulnerability is fixed in 17.4.8 and 17.10.1.
cvss
Technical severity, 0–10. One row per scoring source.
base score 0–10 · higher = more severe · hover a vector to decode⚠ sources disagree · high–critical · 7.3–9.8
ssvc
A stakeholder decision — act, attend, or track — from exploitation and impact.
weaknesses
The CWE weakness classes this flaw belongs to.
exploits (1)
Public proof-of-concept and weaponised exploit code.
- azefzafyoussef/CVE-2026-33229azefzafyoussef/CVE-2026-33229PoC · poc_in_github
affected products (18)
Products and version ranges known to be affected.
- Maven org.xwiki.platform:xwiki-platform-legacy-oldcore17.0.0-rc-1 → 17.4.8osvUSpkg:maven/org.xwiki.platform/xwiki-platform-legacy-oldcore
- Maven org.xwiki.platform:xwiki-platform-legacy-oldcore17.5.0-rc-1 → 17.10.1osvUSpkg:maven/org.xwiki.platform/xwiki-platform-legacy-oldcore
- Maven org.xwiki.platform:xwiki-platform-oldcore17.0.0-rc-1 → 17.4.8osvUSpkg:maven/org.xwiki.platform/xwiki-platform-oldcore
- Maven org.xwiki.platform:xwiki-platform-oldcore17.5.0-rc-1 → 17.10.1osvUSpkg:maven/org.xwiki.platform/xwiki-platform-oldcore
advisories (2)
Vendor and ecosystem advisories describing this.
- WID-SEC-W-2026-1013xwiki: Schwachstelle ermöglicht CodeausführungDeutsch2026-04-08csaf · cert_bundDE
Ein entfernter, authentisierter Angreifer kann eine Schwachstelle in xwiki ausnutzen, um beliebigen Programmcode auszuführen.
- GHSA-h259-74h5-4rh9XWiki vulnerable to remote code execution with script right through unprotected Velocity scripting API2026-04-08ghsa · osvUS
### Impact An improperly protected scripting API allows any user with script right to bypass the sandboxing of the Velocity scripting API and execute, e.g., arbitrary Python scripts, allowing full access to the XWiki instance and thereby compromising the confidentiality, integrity and availability of the whole instance. Note that script right already constitutes a high level of access that we don't recommend giving to untrusted users. ### Patches The vulnerability has been patched in XWiki 17.4.8 and 17.10.1 by requiring programming right to access the affected scripting API. ### Workarounds We're not aware of any workarounds except for being careful whom you grant script right. ### Attribution We thank Youssef Azefzaf for discovering and reporting this vulnerability.
also known as (3)
Other names and identifiers for this entity.
sources
Which sources assert this record, and when.
references (14)
External citations — patches, advisories, analysis.
- https://access.redhat.com/security/cve/cve-2026-33229cnnvd
- https://github.com/xwiki/xwiki-platform/commit/9fe84da66184c05953df9466cf3a4acd15a46e63cnnvd
- https://github.com/xwiki/xwiki-platform/security/advisories/GHSA-h259-74h5-4rh9cnnvd
- https://jira.xwiki.org/browse/XWIKI-23698cnnvd
- https://jira.xwiki.org/browse/XWIKI-23702cnnvd
- https://www.xwiki.org/xwiki/bin/view/Main/WebHomePatchcnnvd
- https://github.com/xwiki/xwiki-platform/commit/9fe84da66184c05953df9466cf3a4acd15a46e63enisa_euvd
- https://github.com/xwiki/xwiki-platform/security/advisories/GHSA-h259-74h5-4rh9enisa_euvd
Attackers weaponise vulnerabilities like this against internet-exposed services. See what is exposed on your perimeter with a free passive scan.
Free scan